Bug 28759 - Amanda amdump failes with lock log file: Invalid Argument
Amanda amdump failes with lock log file: Invalid Argument
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: amanda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-21 21:18 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 21:16:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-21 21:18:48 EST
Using any of the latest rpms from Rawhide, including the ones at http://people.redhat.com/teg/, I get
a clean amcheck but amdump doesn't do anything but complain about not being able to lock its log file.

Steps to Reproduce:
1.Install fresh RedHat 7.0
2.Update amanda RPMs with latest RawHide versions, or teg's copy
3.Turn on Amanda entries in /etc/xinetd.d, restart xinetd
4. su - amanda, /usr/sbin/amdump DailySet1
	
Here's the exact errors, and here I'm using the 2/16 teg RPMs as those look the most recent:

amdump: start at Wed Feb 21 20:51:35 EST 2001
planner: pid 1674 executable /usr/lib/amanda/planner version 2.4.2
planner: build: VERSION="Amanda-2.4.2"
planner:        BUILT_DATE="Fri Feb 16 19:16:01 EST 2001"
planner:        BUILT_MACH="Linux porky.devel.redhat.com 2.2.17-8smp #1 SMP Fri
Nov 17 16:12:17 EST 2000 i686 unknown"
planner:        CC="gcc"
planner: paths: bindir="/usr/bin" sbindir="/usr/sbin"
planner:        libexecdir="/usr/lib/amanda" mandir="/usr/share/man"
planner:        AMANDA_TMPDIR="/tmp/amanda" AMANDA_DBGDIR="/tmp/amanda"
planner:        CONFIG_DIR="/etc/amanda" DEV_PREFIX="/dev/"
planner:        RDEV_PREFIX="/dev/" DUMP="/sbin/dump"
planner:        RESTORE="/sbin/restore" GNUTAR="/bin/tar"
planner:        COMPRESS_PATH="/usr/bin/gzip"
planner:        UNCOMPRESS_PATH="/usr/bin/gzip" MAILER="/usr/bin/Mail"
planner:        listed_incr_dir="/var/lib/amanda/gnutar-lists"
planner: defs:  DEFAULT_SERVER="localhost" DEFAULT_CONFIG="DailySet1"
planner:        DEFAULT_TAPE_SERVER="localhost"
planner:        DEFAULT_TAPE_DEVICE="/dev/null" HAVE_MMAP HAVE_SYSVSHM
planner:        LOCKING=POSIX_FCNTL SETPGRP_VOID DEBUG_CODE BSD_SECURITY
planner:        USE_AMANDAHOSTS CLIENT_LOGIN="amanda" FORCE_USERID HAVE_GZIP
planner:        COMPRESS_SUFFIX=".gz" COMPRESS_FAST_OPT="--fast"
planner:        COMPRESS_BEST_OPT="--best" UNCOMPRESS_OPT="-dc"
driver: could not lock log file /var/lib/amanda/DailySet1/log: Invalid argument
driver: pid 1675 executable /usr/lib/amanda/driver version 2.4.2
READING CONF FILES...
planner: could not lock log file /var/lib/amanda/DailySet1/log: Invalid argument
amdump: end at Wed Feb 21 20:51:35 EST 2001

For completeness sake, here's what amcheck has to say:

Amanda Tape Server Host Check
-----------------------------
WARNING: tapedev is /dev/null, dumps will be thrown away
Holding disk /var/tmp: 14219164 KB disk space available, that's plenty
NOTE: skipping tape checks
NOTE: info dir /var/lib/amanda/DailySet1/curinfo: does not exist
NOTE: it will be created on the next run
NOTE: index dir /var/lib/amanda/DailySet1/index/localhost: does not exist
Server check took 0.001 seconds

Amanda Backup Client Hosts Check
--------------------------------
Client check: 1 host checked in 0.028 seconds, 0 problems found

(brought to you by Amanda 2.4.2)
Comment 1 Trond Eivind Glomsrxd 2001-02-22 12:40:36 EST
Works for me with 2.4.2p1-2 (from http://people.redhat.com/teg/ ):

bash-2.04$ /usr/sbin/amdump DailySet1
bash-2.04$

From amanda  Thu Feb 22 12:37:57 2001
Date: Thu, 22 Feb 2001 12:37:55 -0500
From: Amanda user <amanda@halden.devel.redhat.com>
To: amanda@halden.devel.redhat.com
Subject: DailySet1 AMANDA MAIL REPORT FOR February 22, 2001

These dumps were to tape /dev/null.
The next tape Amanda expects to use is: a new tape.


STATISTICS:
                          Total       Full      Daily
                        --------   --------   --------
Estimate Time (hrs:min)    0:00
Run Time (hrs:min)         0:00
Dump Time (hrs:min)        0:00       0:00       0:00
Output Size (meg)           1.8        1.8        0.0
Original Size (meg)         8.2        8.2        0.0
Avg Compressed Size (%)    21.4       21.4        --
Filesystems Dumped            1          1          0
Avg Dump Rate (k/s)       516.9      516.9        --

Tape Time (hrs:min)        0:00       0:00       0:00
Tape Size (meg)             1.8        1.8        0.0
Tape Used (%)               0.1        0.1        0.0
Filesystems Taped             1          1          0
Avg Tp Write Rate (k/s) 52114.3    52114.3        --

^L
NOTES:
  planner: Adding new disk localhost:/etc.
  taper: tapedev is /dev/null, dumps will be thrown away
  taper: tape /dev/null kb 1824 fm 1 [OK]

^L
DUMP SUMMARY:
                                     DUMPER STATS            TAPER STATS
HOSTNAME     DISK        L ORIG-KB OUT-KB COMP% MMM:SS  KB/s MMM:SS  KB/s
-------------------------- --------------------------------- ------------
localhost    /etc        0    8370   1792  21.4   0:03 516.8   0:0051448.4

(brought to you by Amanda version 2.4.2)

Comment 2 Need Real Name 2001-02-22 21:16:39 EST
I finally tracked down the source of the problem here.  It seems the latest amanda RPMs, while correcting
all of the major problems with xinetd and such, now depend on having a later glibc than is shipped with the 
current RH7 installed.  After upgrading to glibc-2.2-12 with the main and -common RPMs for that package, 
all the amdumps are running fine now on all the machines I've tried this on.

Note You need to log in before you can comment on or make changes to this bug.