Bug 28852 - Internal compiler error in replace_reg when building Crystal Space
Summary: Internal compiler error in replace_reg when building Crystal Space
Status: CLOSED DUPLICATE of bug 27137
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: ftp://ftp.linuxgames.com/crystal/cs01...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-22 14:53 UTC by Fred Wittekind IV
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 14:53:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred Wittekind IV 2001-02-22 14:53:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


libs/csengine/camera.cpp:163: Internal compiler error in replace_reg,
at reg-stack.c:830                                                   

Reproducible: Always
Steps to Reproduce:
1.Download / Install Crystal Space 0.18r001 Source
2.make linux
3.make all
	

Actual Results:  *---------------------------------------------------------
----------------*     
  Building Crystal Space 3D 
engine                                              
  Building for LINUX/GCC/INTEL in optimize 
mode                                 
*-------------------------------------------------------------------------
*     
gcc -c -o out/LINUX/INTEL/optimize/camera.o libs/csengine/camera.cpp -
Wall -Wunused -W -mpentium -march=i586 -fno-exceptions -fno-rtti -O6 -
fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs -
I./plugins -I./support           
libs/csengine/camera.cpp: In method `void csCamera::LookAt (const     
csVector3 &, const csVector3 
&)':                                               
libs/csengine/camera.cpp:163: Internal compiler error in 
replace_reg,           
at reg-
stack.c:830                                                              
Please submit a full bug 
report.                                                
See <URL:http://bugzilla.redhat.com/bugzilla/> for 
instructions.                
make[1]: *** [out/LINUX/INTEL/optimize/camera.o] Error 
1                        

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs  
gcc version 2.96 20000731 (Red Hat Linux 7.0)

Comment 1 Jakub Jelinek 2001-02-22 16:37:46 UTC
This is primarily bug in Crystal Space, I have notified them,
http://sourceforge.net/bugs/?func=detailbug&bug_id=131991&group_id=649
but nobody looked at it so far.

*** This bug has been marked as a duplicate of 27137 ***


Note You need to log in before you can comment on or make changes to this bug.