Bug 28870 - OpenSSH 2.2.0p1-5 & 2.3.0p1-4 both exit abnormally
Summary: OpenSSH 2.2.0p1-5 & 2.3.0p1-4 both exit abnormally
Status: CLOSED DUPLICATE of bug 20687
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-22 15:22 UTC by Derek Price
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 11:58:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Price 2001-02-22 15:22:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


When I attempt to open a shell to another machine with 2.3.0p1-4, and
previously 2.2.0p1-5, installed I get the following error:

    xfree: NULL pointer given as argument

Reproducible: Always
Steps to Reproduce:
1. ssh to another machine with a similar version of SSH installed.
2.
3.
	

Actual Results:  [oberon@empress downloads]$ ssh magus
xfree: NULL pointer given as argument

Expected Results:  Should have opened a secure shell on magus.

There is no core dump.  2.2.0p1-2 and all previous versions since RedHat
6.2 worked fine on this machine.

I can still ssh to a machine with a protocol 1 version of SSH installed:

	Go Blue% /usr/um/ssh/sbin/sshd --version
	/usr/um/ssh/sbin/sshd: illegal option -- -
	sshd version 1.2.27 [sparc-sun-solaris2.6]
	. . .

Here is the failing command with verbose debugging output:

[oberon@empress downloads]$ ssh -v -v -v magus
SSH Version OpenSSH_2.3.0p1, protocol versions 1.5/2.0.
Compiled with SSL (0x0090600f).
debug: Reading configuration data /home/oberon/.ssh/config
debug: Reading configuration data /etc/ssh/ssh_config
debug: Applying options for *
debug: ssh_connect: getuid 500 geteuid 0 anon 1
debug: Connecting to magus [10.0.0.11] port 22.
debug: Connection established.
debug: Remote protocol version 2.0, remote software version OpenSSH_2.3.0p1
debug: no match: OpenSSH_2.3.0p1
Enabling compatibility mode for protocol 2.0
debug: Local version string SSH-2.0-OpenSSH_2.3.0p1
debug: Seeding random number generator
debug: send KEXINIT
debug: done
debug: wait KEXINIT
debug: got kexinit:
diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug: got kexinit: ssh-dss
debug: got kexinit:
3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes128-cbc,aes192-cbc,aes256-cbc,rijndael128-cbc,rijndael192-cbc,rijndael256-cbc,rijndael-cbc@lysator.liu.se
debug: got kexinit:
3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes128-cbc,aes192-cbc,aes256-cbc,rijndael128-cbc,rijndael192-cbc,rijndael256-cbc,rijndael-cbc@lysator.liu.se
debug: got kexinit: hmac-sha1,hmac-md5,hmac-ripemd160@openssh.com
debug: got kexinit: hmac-sha1,hmac-md5,hmac-ripemd160@openssh.com
debug: got kexinit: none,zlib
debug: got kexinit: none,zlib
debug: got kexinit: 
debug: got kexinit: 
debug: first kex follow: 0 
debug: reserved: 0 
debug: done
debug: kex: server->client blowfish-cbc hmac-sha1 none
debug: kex: client->server blowfish-cbc hmac-sha1 none
debug: Sending SSH2_MSG_KEX_DH_GEX_REQUEST.
debug: Wait SSH2_MSG_KEX_DH_GEX_GROUP.
debug: Got SSH2_MSG_KEX_DH_GEX_GROUP.
debug: bits set: 1061/2049
debug: Sending SSH2_MSG_KEX_DH_GEX_INIT.
debug: Wait SSH2_MSG_KEX_DH_GEX_REPLY.
debug: Got SSH2_MSG_KEXDH_REPLY.
debug: Host 'magus' is known and matches the DSA host key.
debug: bits set: 981/2049
xfree: NULL pointer given as argument
debug: Calling cleanup 0x805f3c0(0x0)
[oberon@empress downloads]$

Comment 1 Pekka Savola 2001-02-22 22:54:05 UTC
Do you have a different version of OpenSSL installed than which OpenSSH was compiled against?

Comment 2 Derek Price 2001-02-23 11:58:34 UTC
That was the problem.  I had the 0.9.6-1 OpenSSL libraries from the RedHat
contrib section installed rather than the 0.9.5a-14 which came with RedHat 7.0.

Comment 3 Pekka Savola 2001-02-23 15:33:32 UTC

*** This bug has been marked as a duplicate of 20687 ***


Note You need to log in before you can comment on or make changes to this bug.