Bug 288701 - Charting additional Y-Axises use scaling of first Y-Axis
Summary: Charting additional Y-Axises use scaling of first Y-Axis
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-13 00:23 UTC by Paul Dickson
Modified: 2008-04-04 13:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:00:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gnumeric file of gas prices and mi/gal plotted versus date (4.57 KB, application/octet-stream)
2007-09-13 00:23 UTC, Paul Dickson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 526112 None None None Never

Description Paul Dickson 2007-09-13 00:23:00 UTC
Description of problem:
I'm trying chart two properties gas price and miles/gallon, all versus the date.
 The two gas prices share the same Y scaling.  The third is scaled on the left
side of the chart (correctly).  The plotting of the points for the third is way
off the chart (I added a zero entry to show a known point with a line linking).

Version-Release number of selected component (if applicable):
gnumeric-1.6.3-11.fc8

How reproducible:
Always

Steps to Reproduce:
1. See attached gnumeric file
2. See properties for chart: Graph->Chart1->Y-Axis3 (Scale tab)
3. Data is in Graph->Chart1->PlotXY1->Mi/Gal (Data tab)
  
Actual results:
The zero point is plotted (orange triangle), following points are off the top of
the chart.

Expected results:
All data points plotted

Additional info:

Comment 1 Paul Dickson 2007-09-13 00:23:00 UTC
Created attachment 194151 [details]
Gnumeric file of gas prices and mi/gal plotted versus date

Comment 2 Paul Dickson 2007-09-13 00:55:42 UTC
If I change the maximum scaling of the Y-Axis1 from 4 to 40, the scaling for the
other two Y-Axises also changes and Y-Axis3 data points show up.

Comment 3 Hans de Goede 2008-02-25 13:46:03 UTC
Hi,

Sorry for the long silence.

Rawhide now has gnumeric 1.8.1, can you please check if this bug still happens
with gnumeric-1.8.1 ?


Comment 4 Paul Dickson 2008-02-25 20:25:41 UTC
Yes, 1.8.1 still does it.  In the file attached in Comment #1, it requires that
the values in column G be divided by 10 before they show up in the graph.  The
values are being plotted by the first scale rather than their own.

Comment 5 Hans de Goede 2008-02-25 21:46:37 UTC
(In reply to comment #4)
> Yes, 1.8.1 still does it.  In the file attached in Comment #1, it requires that
> the values in column G be divided by 10 before they show up in the graph.  The
> values are being plotted by the first scale rather than their own.

Ok,

Thanks for testing, I'm afraid I'm not familiar enough with gnumeric's code to
fix this easily, and I expect someone who is familiar with the code to have an
easy time at fixing this. So can you please file this bug upstream:
http://bugzilla.gnome.org/enter_bug.cgi?product=Gnumeric

And then report the upstream ticket number here? Many thanks!


Comment 6 Hans de Goede 2008-04-04 09:00:36 UTC
I've filed this myself upstream now, feel free to add yourself to the CC:
http://bugzilla.gnome.org/show_bug.cgi?id=526112


Comment 7 Hans de Goede 2008-04-04 13:14:40 UTC
FYI: Upstream says this is not a bug, but you are using the charting component
the wrong way causing your issues, they've attached a corrected file which does
behave as you want, see:
http://bugzilla.gnome.org/show_bug.cgi?id=526112



Note You need to log in before you can comment on or make changes to this bug.