Bug 288711 - CDT feature not present in Help -> About Fedora Eclipse -> Feature Details
CDT feature not present in Help -> About Fedora Eclipse -> Feature Details
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 20:55 EDT by Ben Konrath
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: eclipse-cdt-4.0.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 18:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2007-09-12 20:55:44 EDT
Description of problem:

The CDT feature is not present in Help -> About Fedora Eclipse -> Feature
Details. This is because the CDT feature is a jarred plugin but Eclipse expects
features to be unpacked in the eclipse/features/ directory. This message
indicates the problem:

!ENTRY org.eclipse.update.configurator 2007-09-12 20:50:23.335
!MESSAGE Unable to find feature.xml in directory:
/usr/share/eclipse/features/org.eclipse.cdt_4.0.0.200708231819.jar

Version-Release number of selected component (if applicable):

eclipse-cdt-4.0.0-5.fc8.x86_64
Comment 1 Andrew Overholt 2007-09-12 21:03:58 EDT
Jeff, take a look at the patches I added to eclipse-mylyn last week to see how
to unjar a feature.
Comment 2 Jeff Johnston 2007-09-13 18:56:26 EDT
A patch has been made to eclipse-cdt-4.0.0-7 which is currently being built.

Note You need to log in before you can comment on or make changes to this bug.