Bug 28878 - g77 on slow NFS-mounted disks gives incorrect executable
g77 on slow NFS-mounted disks gives incorrect executable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 11:24 EST by Andreas Manschke
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 12:12:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Manschke 2001-02-22 11:24:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.2.16-22 i686)


The fortran program tnix.f:

        program t
        print*,'hallo'
        end

compiles and executes fine when working on local linux,
or NFS-disks on compaq-TRU64 machines.

But, when compiling on a NFS-mounted disk from a rather
old IBM RS/6000 AIX 4.3.2, the executable is mostly (!) broken.

Example:  (Speicherzugriffsfehler means "Memory fault")

/bin/bash
i=1
while [ $i = 1 ]
> do
> g77 -o ./a.out tnix.f
> ./a.out
> done
 hallo
 hallo
 hallo
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
Speicherzugriffsfehler
 hallo
 hallo
 hallo
 hallo
 hallo
 hallo
 hallo
Speicherzugriffsfehler
 hallo
 hallo
Speicherzugriffsfehler

^C

I tried on 4 different RS/6000 and different disks.
The problem is reproducable on all of them.
No problems which gcc or just copy something to NFS-disk.

No problems at all on disks mounted from Linux or Compaq/DEC-Tru64

Reproducible: Sometimes
Steps to Reproduce:
1.Compile Fortran program with g77
2.Execute the result
3. Repeat steps 1. and 2. for a number of times
	

Compiler Versions:

compat-egcs-g77-6.2-1.1.2.9
gcc-g77-2.96-69


gcc-2.96-69
gcc-c++-2.96-69
gcc-objc-2.96-69
kgcc-1.1.2-40


NFS:
nfs-utils-0.1.9.1-7
Comment 1 Jakub Jelinek 2001-02-22 11:42:33 EST
If the bug is on the Linux side, then it is in the kernel, but it may as well
be in the AIX NFS server, that's hard to tell. g77 does not care what filesystem
it reads or write things from and so far I haven't met a gcc bug which would
not be 100% reproducible on the exactly same input with exactly same options.
Comment 2 Michael K. Johnson 2001-02-22 12:12:40 EST
There are known AIX nfs server bugs.  You need to upgrade your
version of AIX.
Comment 3 Andreas Manschke 2001-02-23 10:17:43 EST
You are great !
After upgrading the AIX-nfsd Package and some requirements (800 MB)
the problem is gone.
Thank you!
Andreas Manschke

Note You need to log in before you can comment on or make changes to this bug.