Bug 288801 - Dell D630 has no sound after wakup from suspend/hibernate
Dell D630 has no sound after wakup from suspend/hibernate
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
high Severity medium
: ---
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 02:12 EDT by Huzaifa S. Sidhpurwala
Modified: 2013-01-10 02:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 14:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2007-09-13 02:12:05 EDT
Description of problem:
Dell D630 does not play any sound after wakeup from suspend/hihernate

Version-Release number of selected component (if applicable):

[root@huzaifas ~]# uname -r
2.6.18-47.el5

[root@huzaifas ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.1 Beta (Tikanga)

[root@huzaifas ~]# rpm -q pm-utils
pm-utils-0.99.3-6.el5.12

[root@huzaifas ~]# rpm -q hal
hal-0.5.8.1-23.el5

[root@huzaifas ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory
Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Contoller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2
(rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
03:01.0 CardBus bridge: O2 Micro, Inc. Cardbus bridge (rev 21)
03:01.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755M Gigabit
Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)

[root@huzaifas ~]# rpm -qa | grep alsa
alsa-lib-devel-1.0.14-1.rc4.el5
java-1.5.0-sun-alsa-1.5.0.10-2jpp
alsa-lib-1.0.14-1.rc4.el5
alsa-utils-1.0.14-2.rc4.el5

How reproducible:
Wakup and no sound

Steps to Reproduce:
1.Boot laptop, play sound to test
2.Suspend and wakeup
3.Play sound
  
Actual results:
No sound after wakup

Expected results:
Sound should play

Additional info:
Comment 2 Zdenek Prikryl 2007-09-19 04:47:47 EDT
Hello,
unfortunately I do not have any of those models in my office. But as I found,
the problem is in a sound module. Guys from alsa are working on it.

Could you try plug earphones in and check if the sound is working with disabled
speakers?

One of workarounds is to unload a sound module (snd-hda-intel) before suspend
and after laptop wakes up, load this module again.

I will try to find out more informations.

Zdenek
Comment 3 Huzaifa S. Sidhpurwala 2007-09-19 05:46:25 EDT
Zdenek,
If you want to test, i have the machine here and could assist you with it.
Comment 4 Zdenek Prikryl 2007-09-19 06:11:15 EDT
Go to /etc/pm/config.d/. Check if there are any files. If so, look into them and
try to find a line with SUSPEND_MODULES. If you find such a line, append
"snd-hda-intel" as another module. If there is no such a line or in the
directory /etc/pm/config.d/ is not any file, then create new one with the name
"modules". Write into it SUSPEND_MODULES="snd-hda-intel" and save it.

Then try to suspend/hibernate a laptop via gnome-pover-manager. Also try to
suspend/hibernate a laptop by running command pm-suspend/pm-hibernate in a
terminal as root.

thanks, Zdenek
Comment 5 Huzaifa S. Sidhpurwala 2007-09-20 01:10:14 EDT
Well,
 what is happening is that the function modunload() in
/usr/lib/pm-utils/functions is not able to unload the snd_hda_intel module
strangely enough when i try to unload it myself through modprobe -r or rmmod, it
does not unload, it shows having a dep, but does not show on what it depends on

[root@huzaifas ~]# lsmod | grep snd
snd_hda_intel          24025  1 
snd_hda_codec         202305  1 snd_hda_intel
snd_seq_dummy           7877  0 
snd_seq_oss            32577  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49713  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11725  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42945  0 
snd_mixer_oss          19009  1 snd_pcm_oss
snd_pcm                72133  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              24645  2 snd_seq,snd_pcm
snd                    52421  11
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11553  1 snd
snd_page_alloc         13641  2 snd_hda_intel,snd_pcm


this clearly shows that snd_hda_intel is depended on somthing, but does not show
what?
so the modunload function cannot remove it and hence the purpose is not solved.
Comment 6 Zdenek Prikryl 2007-09-20 03:33:33 EDT
snd_hda_intel is used by some sound applications (probably mixer, or arts,...),
so you have to stop those applications. Then, the module could be removed. But I
think, this is already too complicated.

Let's try this workaround.
In /etc/modprobe.conf, add:

options snd-card-0 model=3stack
options snd-hda-intel model=3stack

Reboot a laptop and then try to suspend/hibernate.
Comment 7 Huzaifa S. Sidhpurwala 2007-09-20 04:33:36 EDT
Not working with that,
mixer is depenent to snd_hda_intel,so when i remove mixer, it works fine 
Comment 9 Huzaifa S. Sidhpurwala 2008-02-06 22:11:13 EST
Anything on this yet?
Comment 10 Rui Matos 2008-03-12 19:24:51 EDT
Hi, this bug happened to me on Fedora 7 and, sadly, continues on Fedora 8 on
this same hardware. Since this bug is about RedHat EL 5 should I file a new bug
for fedora? Or is there any debug info I can get to help fix this?
Comment 11 Matthew Garrett 2009-03-12 03:59:04 EDT
Is this still an issue? My D630 running 5.3 appears to have working sound after resume. There have been significant ALSA updates to provide HDA support, so I suspect that this bug has been fixed since the last update.
Comment 12 Huzaifa S. Sidhpurwala 2009-04-08 05:19:31 EDT
works for me on a 5.3 machine
Comment 13 John Feeney 2009-05-13 14:51:28 EDT
Since the bug reporter says it works in RHEL 5.3, I am going to close this as CLOSED WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.