Bug 28927 - PPP seems not to detach from terminal when using demand dialing.
PPP seems not to detach from terminal when using demand dialing.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 16:31 EST by Graham Cole
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 16:55:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Cole 2001-02-22 16:31:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


When using the "DEMAND=yes" option in my ifcfg-ppp0, typing ifup ppp0
never returns even after a connect.  This will also make init get stuck on
boot.

Reproducible: Always
Steps to Reproduce:
1. Configure a PPP connection.
2. Select the demand option (Bring link up and down automatically in rp3)
3. type ifup ppp0
	

Actual Results:  instead of configuring the interface and returning control
to the shell, it prints out all info to the terminal and never detaches,
even after the ppp link is established.
After commenting out the DEMAND line in ifcfg-ppp0 it dials up fine and
detaches once connected.

see the output below:

Expected Results:  [root@charon /root]# ifup ppp0
Using interface ppp0
local  IP address 10.64.64.64
remote IP address 10.112.112.112
Starting link
--> WvDial: Internet dialer version 1.41
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT 990-8604
--> Waiting for carrier.
ATDT 990-8604
CONNECT 26400 V42bis
--> Carrier detected.  Waiting for prompt.
UQKT2 tnt12.sjc4.da.uu.net
Login: 
--> Looks like a login prompt.
--> Sending: mylogin
mylogin
Password: 
--> Looks like a password prompt.
--> Sending: (password)
    Entering PPP Session.
    IP address is 63.39.137.154
    MTU is 1524.
--> Looks like a welcome message.
Serial connection established.
Connect: ppp0 <--> /dev/ttyS2
Local IP address changed to 63.39.137.154
Remote IP address changed to 206.115.222.247



#here is my ifcfg-ppp0:
DEVICE=ppp0
NAME=MyISP
WVDIALSECT=MyISP
MODEMPORT=/dev/ttyS2
LINESPEED=57600
PAPNAME=mylogin
USERCTL=true
ONBOOT=no
PERSIST=yes
DEFROUTE=yes
PEERDNS=yes
IDLETIMEOUT=600
DEMAND=yes
Comment 1 Glen Foster 2001-02-23 16:55:30 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Nalin Dahyabhai 2001-02-28 11:28:56 EST
I believe this is fixed in initscripts-5.69 and later, which should appear in
Raw Hide in the next refresh (ppp-watch wasn't being used to control pppd if
demand-dialing was enabled, and it just got weird in there).  Please reopen this
bug if you find that it doesn't work correctly.
Comment 3 Ed McKenzie 2001-05-20 15:04:18 EDT
This is still broken for me in 7.1-release.
Comment 4 Joel Griffiths 2001-07-13 13:29:35 EDT
I worked around this on my home system by adding an ampersand to the end of exec
/usr/sbin/pppd command (after ${PPPOPTIONS}). The -detach flag is being sent to
pppd, but it doesn't return. I installed all redhat updates to no avail. PPP
worked fine after adding the ampersand. It's a lazy workaround, but it works.

Note You need to log in before you can comment on or make changes to this bug.