Bug 289401 - Bug Section in man nfs is wrong
Bug Section in man nfs is wrong
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.5
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Layton
:
Depends On:
Blocks: 425954
  Show dependency treegraph
 
Reported: 2007-09-13 12:16 EDT by Steve Dickson
Modified: 2014-06-18 03:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0751
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2007-09-13 12:16:06 EDT
Description of problem:
The bug section states:

       The  posix,  and  nocto  options are parsed by mount but currently are
       silently ignored.

Which is wrong because the notco option is not ignored. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Layton 2007-09-28 14:04:34 EDT
Actually, this whole section has problems:

       The posix, and nocto options are parsed by  mount  but  currently  are
       silently ignored.

mount sets the "posix" flag but the kernel ignores it. nocto works.

       The  tcp and namlen options are implemented but are not currently sup-
       ported by the Linux kernel.

"tcp" definitely works. Looks like the kernel sets the nfs_server namelen field
from this name, but it's not clear to me what that actually does...

       The umount command should notify the server when an NFS filesystem  is
       unmounted.

I'm pretty sure that umount sends a call over the wire.
Comment 2 Jeff Layton 2007-09-28 14:06:14 EDT
Ahh namelen works too, it appears.

Also, RHEL5 has the same exact BUGS section in the manpage. Steve, do you have a
RHEL5 bug for this open already, or should I clone this?
Comment 3 Jeff Layton 2007-09-28 15:51:13 EDT
nfs.5 is part of util-linux on RHEL4.
Comment 4 RHEL Product and Program Management 2007-11-28 22:58:27 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Jeff Layton 2008-02-29 12:56:37 EST
Committed in util-linux-2.12a-18.el4
Comment 10 errata-xmlrpc 2008-07-24 16:01:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0751.html

Note You need to log in before you can comment on or make changes to this bug.