Bug 28950 - core dump when iwconfig is run
core dump when iwconfig is run
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 20:22 EST by Need Real Name
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 20:22:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-22 20:22:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-8.R i686)


iwconfig will spit out the correct information but then core dump .. was
this compiled with the wrong kernel headers?? After recompiling the src.rpm
on the 7.1B machine the utilities work fine

Reproducible: Always
Steps to Reproduce:
1.iwconfig
2.
3.
	

Actual Results:  eth0      IEEE 802.11-DS  ESSID:"eazel" 
Nickname:"localhost.localdomain"
          Frequency:2.422GHz  Sensitivity:1/3  Mode:Managed  
          Access Point: 00:60:1D:1C:33:AA
          Bit Rate:11Mb/s   RTS thr:off   Fragment thr:off   
          Power Management:off
          Link quality:26/92  Signal level:-71 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  invalid crypt:0  invalid misc:1110

segmentation fault (core dump)

Expected Results:  no seggy :)
Comment 1 Bill Nottingham 2001-02-22 21:48:18 EST
Fixed in the wolverine package.

Note You need to log in before you can comment on or make changes to this bug.