Bug 28955 - various screensavers dumps core
various screensavers dumps core
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 28956 29138 40572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 22:56 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 10:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace of screen saver core dump on Redhat 8.0 system (442 bytes, text/plain)
2003-03-20 14:25 EST, Robert Trask
no flags Details

  None (edit)
Description Need Real Name 2001-02-22 22:56:23 EST
The shadebobs dumbs core. The trace is attached
(the symbols are stripped in the binary, so the trace 
 is not very useful).
core file is available upon request

Vesion:
rpm -q xscreensaver
xscreensaver-3.25-4



gdb /usr/X11R6/lib/xscreensaver/shadebobs core
.....

Loaded symbols for /lib/libm.so.6
---Type <return> to continue, or q <return> to quit---
Reading symbols from /lib/libc.so.6...
done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x804a1e5 in strcpy () at ../sysdeps/generic/strcpy.c:31
31	../sysdeps/generic/strcpy.c: No such file or directory.
(gdb) 
(gdb) bt
#0  0x804a1e5 in strcpy () at ../sysdeps/generic/strcpy.c:31
#1  0xc1c9 in ?? ()
#2  0x804a5da in strcpy () at ../sysdeps/generic/strcpy.c:31
#3  0x804b5de in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x401b9b5c in __libc_start_main (main=0x804ae30 <strcpy+6392>, argc=2, 
    ubp_av=0xbffffac4, init=0x8049098 <_init>, fini=0x804f91c <_fini>, 
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffabc)
    at ../sysdeps/generic/libc-start.c:129
(gdb)
Comment 1 Bill Nottingham 2001-02-22 23:38:22 EST
Can you try the xscreensaver from the wolverine beta? There
was a bug in shadebobs fixed in 3.26.
Comment 2 Bill Nottingham 2001-05-14 14:34:05 EDT
Without the debugging symbols, the traces aren't useful.

I don't see *any* of these here.
Comment 3 Bill Nottingham 2001-05-14 14:34:14 EDT
*** Bug 28956 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-05-14 14:34:40 EDT
*** Bug 29138 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2001-05-14 14:35:06 EDT
*** Bug 40572 has been marked as a duplicate of this bug. ***
Comment 6 Need Real Name 2001-05-14 14:50:11 EDT
>Without the debugging symbols, the traces aren't useful.
> I don't see *any* of these here.

It is hard for me to get more debugging info,
I just found a 'core' file in my home directory.

Also, because so many xscreensaver programs dump core
may be it make sense not to strip debugging symbols
when building an rpm
Comment 7 Bill Nottingham 2001-05-14 14:52:12 EDT
That's just the thing.

They *don't* dump core on any machine I've seen.
Comment 8 Need Real Name 2001-05-14 14:57:08 EDT
>That's just the thing.
>They *don't* dump core on any machine I've seen.

All these core file were collected from 5 different RedHat 7.0 workstations
(with all updates applied)
with different hardware (i586, i686), memory (from 32Mb to 512Mb)
and disks.

At least one core file was found on every of these 5 computers.
Comment 9 Bill Nottingham 2001-05-14 15:12:33 EDT
Odd, we've never seen anything like this in testing here. Do these machines
have *anything* in common?  (processor type/speed, graphics card, etc.)

You can try http://people.redhat.com/notting/xscreensaver/ ; there are binary
RPMs built there with debugging symbols...
Comment 10 Need Real Name 2001-05-14 15:28:00 EDT
No, everything is different in these machines.

The only thing in common that some of them may stay for a a day or two
with screensaver running and monitor power turned off.
Comment 11 Need Real Name 2001-05-14 15:30:51 EDT
I will put this RPM with screensaver on three of these computers.
Comment 12 Need Real Name 2001-05-14 16:47:15 EDT
This one just crashed

gdb /usr/X11R6/lib/xscreensaver/xrayswarm core 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
Core was generated by `/usr/X11R6/lib/xscreensaver/xrayswarm'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXmu.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0xe332dd89 in ?? ()
(gdb) bt
#0  0xe332dd89 in ?? ()
#1  0x804c223 in screenhack_handle_events (dpy=0xbffff630) at screenhack.c:239
#2  0x804ba84 in screenhack (d=0x4, w=3221222960) at xrayswarm.c:1056
#3  0x804cc4e in main (argc=1, argv=0xbffffa84) at screenhack.c:584
#4  0x401bcf31 in __libc_start_main (main=0x804c490 <main>, argc=1, 
    ubp_av=0xbffffa84, init=0x8048f68 <_init>, fini=0x804e30c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffa7c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
Comment 13 Bill Nottingham 2001-05-15 12:22:24 EDT
Are the machines, even though they have different hardware, running at
the same bpp or screen resolution?
Comment 14 Need Real Name 2001-05-15 13:44:54 EDT
The resolution is the same 1024x768 
bpp and frequencies are different.

I seems being able to get one crash with xrayswarm (the others dod not crash
yet)
when using a package compiled with debugging symbols.
It seems crashes in 
0x804c223 in screenhack_handle_events (dpy=0xbffff630) at screenhack.c:239
(see above)

I will wait for few weeks, may be I will be able to collect more core files.
Comment 15 Jamie Zawinski 2002-07-27 02:07:40 EDT
I don't know what could be causing such a widespread set of crashes, but
screenhack_handle_events just does this:

  while (XPending (dpy))
    {
      XEvent event;
      XNextEvent (dpy, &event);
      screenhack_handle_event (dpy, &event);
    }

so unless "dpy" is corrupted memory, I don't see how that could be crashing. 
Chances are there's an upstream memory corruption, and this is just where it
finally manifests.

If you have reproducible crashes: does adding --sync alter the behavior?
Comment 16 Robert Trask 2003-03-20 14:25:05 EST
Created attachment 90676 [details]
gdb backtrace of screen saver core dump on Redhat 8.0 system

I am seeing core dumps from various screen savers on Redhat 8.0. The attachment
is a gdb bt of one of the core files.
Comment 17 Jamie Zawinski 2003-03-20 14:33:09 EST
I've also seen this on RH8, and as far as I can tell, it's a bug in whatever
version of Mesa GL they're shipping with whatever version of XFree86 they're
shipping (I don't remember the numbers, but as of last week, I was running the
latest version for which RPMs are available anywhere.)

This GL stuff is doubtless unrelated to the earlier stuff in this bug report
about screenhack_handle_events.

Please report this to whoever is responsible for OpenGL in RH8?
Comment 18 Bill Nottingham 2003-03-20 16:41:48 EST
Adding the X maintainer for the r128 DRI crash.
Comment 19 Bill Nottingham 2003-03-20 16:45:36 EST
Removing X maintainer, r128 bug filed separately as bug 86368.
Comment 20 Stephen Samuel 2003-07-13 09:32:12 EDT
may be a duplicate of Bug #73827
Comment 21 Ray Strode [halfline] 2004-11-09 10:54:28 EST
Hi,

This bug report is very old and the problem reported is probably fixed
by now.  I'm going to close this report, but if you encounter the
problem in FC3 or with a recent version of xscreensaver, please feel
free to reopen.

Note You need to log in before you can comment on or make changes to this bug.