Bug 28956 - sonar dumps core
Summary: sonar dumps core
Status: CLOSED DUPLICATE of bug 28955
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 03:59 UTC by Need Real Name
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 05:11:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-23 03:59:16 UTC
sonar dumps core
gdb /usr/X11R6/lib/xscreensaver/sonar core
.....

Loaded symbols for /lib/ld-linux.so.2
#0  0x402178b9 in chunk_free (ar_ptr=0x402b8680, p=0x805ddb8) at
malloc.c:3131
3131	malloc.c: No such file or directory.
(gdb) bt
#0  0x402178b9 in chunk_free (ar_ptr=0x402b8680, p=0x805ddb8) at
malloc.c:3131
#1  0x40217828 in __libc_free (mem=0x805ddc0) at malloc.c:3054
#2  0x804d4a9 in strcpy () at ../sysdeps/generic/strcpy.c:31
#3  0x804a968 in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x804bf7b in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x804cffe in strcpy () at ../sysdeps/generic/strcpy.c:31
#6  0x401b9b5c in __libc_start_main (main=0x804c850 <strcpy+11724>, argc=2, 
    ubp_av=0xbffffac4, init=0x8049484 <_init>, fini=0x80502fc <_fini>, 
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffabc)
    at ../sysdeps/generic/libc-start.c:129
(gdb)

Comment 1 Bill Nottingham 2001-02-23 04:38:59 UTC
Multiple bugs in the sonar screensaver have been fixed in the current
version (3.29-1); please reopen if it persists for you.

Comment 2 Need Real Name 2001-02-24 05:11:07 UTC
The sonar from 

rpm -q xscreensaver
xscreensaver-3.29-1

dumps core when started from xscreensaver-demo

 gdb /usr/X11R6/lib/xscreensaver/sonar core
....
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x402178b9 in chunk_free (ar_ptr=0x402b8680, p=0x805dbf0) at malloc.c:3131
3131	malloc.c: No such file or directory.
(gdb) 
(gdb) bt
#0  0x402178b9 in chunk_free (ar_ptr=0x402b8680, p=0x805dbf0) at malloc.c:3131
#1  0x40217828 in __libc_free (mem=0x805dbf8) at malloc.c:3054
#2  0x804d327 in strcpy () at ../sysdeps/generic/strcpy.c:31
#3  0x804a938 in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x804befb in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x804cf3e in strcpy () at ../sysdeps/generic/strcpy.c:31
#6  0x401b9b5c in __libc_start_main (main=0x804c780 <strcpy+11592>, argc=2, 
    ubp_av=0xbffffb04, init=0x8049460 <_init>, fini=0x805013c <_fini>, 
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffafc)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 

Strange thing, it seems works OK when started from a termibal 
using the same command as xscreensaver-demo.

Also I would recommend to put not-stripped binaries
into xscreensaver rpm. The programs from xscreensaver 
seems crash so often that this would worth few extra bytes.
Just check several RedHat 7.0 workstations on a subject of 
core files in the home directories. It will be a lot of them
generated by xscreensaver.

Comment 3 Bill Nottingham 2001-05-14 18:34:19 UTC

*** This bug has been marked as a duplicate of 28955 ***


Note You need to log in before you can comment on or make changes to this bug.