Bug 289711 - Filesystem corruption in kernel-2.6.22.5-76.fc7.x86_64
Filesystem corruption in kernel-2.6.22.5-76.fc7.x86_64
Status: CLOSED DUPLICATE of bug 286501
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 14:28 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 15:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current output of 'dmesg' (28.88 KB, text/plain)
2007-09-13 14:28 EDT, Ashish Shukla
no flags Details

  None (edit)
Description Ashish Shukla 2007-09-13 14:28:09 EDT
Description of problem:
Filesystem corrupted. I've received I/O error when "emacs" is trying to rename 
a file 
"/home/wahjava/mail/sent-mail/.nnmaildir/nov/1180075218.V806I5e7b73M926791.chatteau.d.lf:" 
to "/home/wahjava/mail/sent-mail/.nnmaildir/nov/1180075218.V806I5e7b73M926791.chatteau.d.lf" .

Version-Release number of selected component (if applicable):
kernel-2.6.22.5-76.fc7

How reproducible:
Not reproducible.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Following is an excerpt from /var/log/messages:
-- begin /var/log/messages --
Sep 13 23:14:07 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, inode=458777, 
rec_len=21, name_len=8
Sep 13 23:14:39 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=4282056519, rec_len=65396, name
_len=106
Sep 13 23:14:39 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=4282056519, rec_len=65396, name
_len=106
Sep 13 23:14:48 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4282056519, rec_len=227, name_len=8
Sep 13 23:14:48 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4282056519, rec_len=227, name_len=8
Sep 13 23:14:49 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len is too small 
for name_len - offset=19556, inode=14745838, rec_len=220, name
_len=213
Sep 13 23:14:49 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len is too small 
for name_len - offset=19556, inode=14745838, rec_len=220, name
_len=213
Sep 13 23:14:55 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=851948, rec_len=37, name_len=72
Sep 13 23:14:55 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=851948, rec_len=37, name_len=72
Sep 13 23:15:12 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=13238472, rec_len=239, name_len=244
Sep 13 23:16:00 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: inode out of bounds - offset=3172, 
inode=25690466, rec_len=292, name_len=75
Sep 13 23:19:00 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: directory entry across blocks - offset=3172, 
inode=4265803333, rec_len=65172, name_len=141
Sep 13 23:20:30 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: inode out of bounds - offset=3172, 
inode=29032913, rec_len=428, name_len=154
Sep 13 23:21:02 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=4271111827, rec_len=65166, name_len=138
Sep 13 23:21:21 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=14024926, rec_len=282, name_len=23
Sep 13 23:21:21 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=14024926, rec_len=282, name_len=23
Sep 13 23:21:23 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=4286447489, rec_len=65368, name
_len=90
Sep 13 23:21:24 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=11403426, rec_len=217, name_len=231
Sep 13 23:21:24 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=11403426, rec_len=217, name_len=231
Sep 13 23:21:51 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=4282515250, rec_len=65318, name_len=40
Sep 13 23:23:22 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=4292345826, rec_len=65518, name_len=236
Sep 13 23:24:35 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=12714180, rec_len=229, name_len=244
Sep 13 23:24:35 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=12714180, rec_len=229, name_len=244
Sep 13 23:24:44 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=12714180, rec_len=65251, name_len=231
Sep 13 23:25:01 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=4285464432, rec_len=65387, name_len=112
Sep 13 23:25:22 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4285464432, rec_len=65387, name_len=112
Sep 13 23:25:22 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4285464432, rec_len=65387, name_len=112
Sep 13 23:26:45 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: rec_len % 4 != 0 - offset=3172, 
inode=4279304146, rec_len=65509, name_len=39
Sep 13 23:26:58 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=4285923212, rec_len=65432, name
_len=95
Sep 13 23:26:58 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=4285923212, rec_len=65432, name
_len=95
Sep 13 23:27:00 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4293066699, rec_len=65507, name_len=200
Sep 13 23:27:02 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=11599712, rec_len=65378, name_len=120
Sep 13 23:27:07 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: rec_len % 4 != 0 - 
offset=19556, inode=4277272557, rec_len=65534, name_len=175
Sep 13 23:27:08 chatteau kernel: EXT3-fs error (device sda6): 
htree_dirblock_to_tree: bad entry in directory #6215940: directory entry 
across blocks - offset=19556, inode=16580476, rec_len=65372, name_l
en=64
Sep 13 23:27:29 chatteau kernel: EXT3-fs error (device sda6): ext3_add_entry: 
bad entry in directory #6215940: directory entry across blocks - offset=3172, 
inode=16580476, rec_len=65372, name_len=64
-- end /var/log/messages --

After restarting, automatic fsck gets started which terminated with a message 
saying I need to manually execute fsck without "-a" or "-p" option.

Expected results:
No filesystem corruption should take place.


Additional info:
My box is running perfectly fine since 2-3 weeks, no hangs, no unexpected 
restarts.
Comment 1 Ashish Shukla 2007-09-13 14:28:09 EDT
Created attachment 194921 [details]
Current output of 'dmesg'
Comment 2 Eric Sandeen 2007-09-13 14:54:56 EDT
Has the fs been repaired yet?  could you make an e2image of it if not?

I'm chasing a somewhat similar corruption at the moment, though slightly
different style of htree-format problems from the reproducer I have...

-Eric
Comment 3 Ashish Shukla 2007-09-13 15:10:04 EDT
I've repaired my fs :(, as this is my production fs.
Comment 4 Eric Sandeen 2007-09-13 23:33:24 EDT
Ashish, I understand... any chance you have logs from the e2fsck still?

Thanks,

-Eric
Comment 5 Ashish Shukla 2007-09-13 23:42:20 EDT
I've not explicitly redirected output of fsck anywhere, but if it implicitly 
logs somewhere, please tell me, I'll upload that log.
Comment 6 Eric Sandeen 2007-09-13 23:57:11 EDT
No, it doesn't.  That's ok, just looking for clues.

I'm chasing one case I can reproduce where a newly-split leaf block does not
contain enough space for the new directory entry... your message:

   bad entry in directory #6215940: rec_len is too small for name_len -
offset=19556, inode=14745838, rec_len=220, name_len=213

looks a like it might be related.
Comment 7 Eric Sandeen 2007-09-17 15:48:01 EDT
Based on the long filename you were trying to rename, I'm going to assume for
now that this is a dup.  There's not really any other info to go on, I'm afraid.

I sent this upstream today:
http://marc.info/?l=linux-ext4&m=119005010917843&w=2

I tested it with the testcase at:
http://marc.info/?l=linux-ext4&m=118067140512836&w=2

-Eric

*** This bug has been marked as a duplicate of 286501 ***

Note You need to log in before you can comment on or make changes to this bug.