Bug 290151 - Pulseaudio not starting - permission problem?
Pulseaudio not starting - permission problem?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 17:54 EDT by Adam Huffman
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 13:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modprobe.conf.dist file (5.58 KB, application/octet-stream)
2007-10-02 23:59 EDT, Mike Chambers
no flags Details

  None (edit)
Description Adam Huffman 2007-09-13 17:54:03 EDT
Description of problem:
Pulseaudio doesn't seem to start properly, meaning that I can't play any sounds.
This is on a system with rawhide installed from scratch and regularly updated.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.11.svn20070907.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Output of pulseaudio -vv:

[root@vaio ~]# pulseaudio -vv
W: main.c: This program is not intended to be run as root (unless --system is
specified).
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0'
E: module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0'
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 0 "alsa_input.pci_8086_27d8_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+10
I: module.c: Loaded "module-alsa-source" (index: #0; argument: "device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0").
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_control__1
I: module-hal-detect.c: Loaded 1 modules.
I: module.c: Loaded "module-hal-detect" (index: #1; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #2; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #3; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #4; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #5; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #6; argument: "").
D: module-suspend-on-idle.c: Source alsa_input.pci_8086_27d8_alsa_capture_0
becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #7; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules//module-x11-publish.so': failure
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules//module-gconf.so': failure
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_27d8_alsa_capture_0 idle
for too long, suspending ...
I: module-alsa-source.c: Device suspended...
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device,
path=/org/freedesktop/Hal/devices/acpi_BAT1, member=PropertyModified

cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xdc340000 irq 21
Comment 1 Mike Chambers 2007-09-14 06:22:51 EDT
[mike@scrappy ~]$ pulseaudio -vv
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1039_7012_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments
'device=hw:1 sink_name=alsa_output.pci_1039_7012_alsa_playback_0'
ALSA lib pcm_hw.c:1351:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:1: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument:
"device=hw:1 sink_name=alsa_output.pci_1039_7012_alsa_playback_0"):
initialization failed.
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1039_7012_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments
'device=hw:1 source_name=alsa_input.pci_1039_7012_alsa_capture_0'
ALSA lib pcm_hw.c:1351:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:1: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument:
"device=hw:1 source_name=alsa_input.pci_1039_7012_alsa_capture_0"):
initialization failed.
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1039_7012_alsa_capture_0
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_3
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_3
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_2
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_2
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_1
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments
'device=hw:0 sink_name=alsa_output.pci_1102_7_alsa_playback_0'
ALSA lib pcm_hw.c:1351:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument:
"device=hw:0 sink_name=alsa_output.pci_1102_7_alsa_playback_0"):
initialization failed.
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments
'device=hw:0 source_name=alsa_input.pci_1102_7_alsa_capture_0'
ALSA lib pcm_hw.c:1351:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument:
"device=hw:0 source_name=alsa_input.pci_1102_7_alsa_capture_0"):
initialization failed.
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_0
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_midi_0
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1039_7012_alsa_control__1
D: module-hal-detect.c: Not loaded
device /org/freedesktop/Hal/devices/pci_1102_7_alsa_control__1
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument:
"").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument:
"").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #4;
argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #7; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #8; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired

[mike@scrappy ~]$ more /proc/asound/cards
 0 [CA0106         ]: CA0106 - CA0106
                      Audigy SE [SB0570] at 0xe300 irq 22
 1 [SI7012         ]: ICH - SiS SI7012
                      SiS SI7012 with ALC655 at irq 23
Comment 2 Lennart Poettering 2007-09-23 20:34:07 EDT
In the first dump something is blocking your soundcard: are you running an
application that is playing audio/blocking it?

In the second dump there's something wrong with your ALSA setup, because we
cannot open the ALSA devices. Please check in the device files are properly
created in /dev/snd, and whether "aplay -f cd -D hw:1" works.

Neither is a PulseAudio bug, but we'll keep it assigned to PA for now, until I
get more information on this.
Comment 3 Mike Chambers 2007-09-24 00:49:15 EDT
[mike@scrappy snd]$ pwd
/dev/snd
[mike@scrappy snd]$ ls -la
total 0
drwxr-xr-x   2 root root     360 2007-09-22 18:44 .
drwxr-xr-x  12 root root    4740 2007-09-22 18:45 ..
crw-rw----+  1 root root 116, 13 2007-09-22 18:44 controlC0
crw-rw----+  1 root root 116, 17 2007-09-22 18:44 controlC1
crw-rw----+  1 root root 116,  4 2007-09-22 18:44 midiC0D0
crw-rw----+  1 root root 116, 12 2007-09-22 18:44 pcmC0D0c
crw-rw----+  1 root root 116, 11 2007-09-22 18:44 pcmC0D0p
crw-rw----+  1 root root 116, 10 2007-09-22 18:44 pcmC0D1c
crw-rw----+  1 root root 116,  9 2007-09-22 18:44 pcmC0D1p
crw-rw----+  1 root root 116,  8 2007-09-22 18:44 pcmC0D2c
crw-rw----+  1 root root 116,  7 2007-09-22 18:44 pcmC0D2p
crw-rw----+  1 root root 116,  6 2007-09-22 18:44 pcmC0D3c
crw-rw----+  1 root root 116,  5 2007-09-22 18:44 pcmC0D3p
crw-rw----+  1 root root 116, 16 2007-09-22 18:44 pcmC1D0c
crw-rw----+  1 root root 116, 15 2007-09-22 18:44 pcmC1D0p
crw-rw----+  1 root root 116, 14 2007-09-22 18:44 pcmC1D1c
crw-rw----+  1 root root 116,  3 2007-09-22 18:44 seq
crw-rw----+  1 root root 116,  2 2007-09-22 18:44 timer
Comment 4 Lennart Poettering 2007-09-25 09:16:35 EDT
Does "aplay -f cd -D hw:1" work? 
Comment 5 Mike Chambers 2007-09-25 10:01:31 EDT
[mike@scrappy ~]$ aplay -f cd -D hw:1
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
aplay: main:546: audio open error: No such device

Above was done as normal user...

[root@scrappy ~]# aplay -f cd -D hw:1
Aborted by signal Interrupt...

As root above it just sits there after hitting enter and doesn't do anything
(this after waiting bout 30 seconds or so).  I just hit control + c to get it to
exit.

Not sure what it should do when performing that command?
Comment 6 Lennart Poettering 2007-09-25 12:23:22 EDT
It just tries to open the audio device.

Apparently you have a permission issue (possibly selinux). Could you please run
this line and paste the output:

strace -e open aplay -f cd -D hw:1 /dev/urandom

And then, restart HAL? and run this line again?

This is no PA bug, btw. 
Comment 7 Lennart Poettering 2007-09-25 13:09:19 EDT
Are you running selinux in enforcing mode?
Comment 8 David Zeuthen 2007-09-25 13:11:52 EDT
getenforce will tell you whether you are running in enforcing mode. If you are,
please try booting with enforcing=0 (go into grub) and see if the bug still
appears. Btw, see bug 287941 for discussion of the SELinux bug. Thanks.
Comment 9 Lennart Poettering 2007-09-25 14:34:56 EDT
bug 291271 might also be the problem.
Comment 10 Mike Chambers 2007-09-25 18:03:26 EDT
selinux hasn't ran since the install, as I always turn it off.  I Have to do a
reinstall anyway for various reasons and will report back if there is a problem
or not.
Comment 11 Mike Chambers 2007-09-26 22:51:45 EDT
I reinstalled F8t2 earlier today and sound worked just fine (regular sounds,
everything).

I update the system to get it updated with rawhide as of this morning and sound
quit working.  Sound detection works fine, but the sound icon in my panel does
not, such as before.

So something between t2 and today has broken it (well a few days ago anyway). 
Does this maybe need to go ahead and be changed to a different component (but
which one)?
Comment 12 Mike Chambers 2007-09-26 22:56:27 EDT
[root@scrappy init.d]# strace -e open aplay -f cd -D hw:1 /dev/urandom
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib/libasound.so.2", O_RDONLY)   = 3
open("/lib/libm.so.6", O_RDONLY)        = 3
open("/lib/libdl.so.2", O_RDONLY)       = 3
open("/lib/libpthread.so.0", O_RDONLY)  = 3
open("/lib/libc.so.6", O_RDONLY)        = 3
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 3
open("/etc/alsa/alsa.conf", O_RDONLY)   = 3
open("/dev/snd/controlC1", O_RDONLY)    = 3
open("/dev/snd/controlC1", O_RDWR)      = 3
open("/dev/snd/pcmC1D0p", O_RDWR|O_NONBLOCK) = 4
open("/dev/urandom", O_RDONLY|O_LARGEFILE) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 5
open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US.utf8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
Playing raw data '/dev/urandom' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 

[root@scrappy init.d]# service haldaemon restart
Stopping HAL daemon:                                       [  OK  ]
Starting HAL daemon:                                       [  OK  ]

[root@scrappy init.d]# strace -e open aplay -f cd -D hw:1 /dev/urandom
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/lib/libasound.so.2", O_RDONLY)   = 3
open("/lib/libm.so.6", O_RDONLY)        = 3
open("/lib/libdl.so.2", O_RDONLY)       = 3
open("/lib/libpthread.so.0", O_RDONLY)  = 3
open("/lib/libc.so.6", O_RDONLY)        = 3
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 3
open("/etc/alsa/alsa.conf", O_RDONLY)   = 3
open("/dev/snd/controlC1", O_RDONLY)    = 3
open("/dev/snd/controlC1", O_RDWR)      = 3
open("/dev/snd/pcmC1D0p", O_RDWR|O_NONBLOCK) = 4
open("/dev/urandom", O_RDONLY|O_LARGEFILE) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 5
open("/usr/share/locale/en_US.UTF-8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US.utf8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/alsa-utils.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
Playing raw data '/dev/urandom' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 
Comment 13 Lennart Poettering 2007-10-01 13:23:47 EDT
So, apparently raw ALSA works fine now. Could you please paste the output of
"pulseaudio -vv" here?

(Might require a "pulseaudio -k" first)

And could you please be a little bit more elaborate what exactly doesn't work
and what the error messages are?
Comment 14 Mike Chambers 2007-10-01 23:31:16 EDT
Sound doesn't work at all, except only when performing the sound detection. 
Also, the volume control icon on the panel has the little red X by it.  Now, not
sure if this is related, but I also have programs (k3b, xcdroast) that won't
detect my cdrom nor my dvd player, and both of these are shown as detected while
the system is booting up.  So I am wondering if there is some sort of
permissions problem with all this or not?  Something in the upgrade sine t2? 
Anyway, here are the couple error messages I see..

1 - Rick click icon, click on "Open Volume Control". You get the message below
in a menu..

No volume control GStreamer plugins and/or devices found.

If you click on preferences, nothing comes up (no menu or anything).

[mike@scrappy ~]$ pulseaudio -k
[mike@scrappy ~]$ pulseaudio -vv
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1039_7012_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:1
sink_name=alsa_output.pci_1039_7012_alsa_playback_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:1: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:1
sink_name=alsa_output.pci_1039_7012_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1039_7012_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:1
source_name=alsa_input.pci_1039_7012_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:1: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:1
source_name=alsa_input.pci_1039_7012_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1039_7012_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_3
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_3
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_1102_7_alsa_playback_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_1102_7_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_1102_7_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_1102_7_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_midi_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1039_7012_alsa_control__1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1102_7_alsa_control__1
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #7; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #8; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
Comment 15 Mike Chambers 2007-10-02 08:14:28 EDT
Don't know if this helps, but this is in my logs after reboot..

Oct  1 05:19:09 scrappy pulseaudio[2037]: module-alsa-sink.c: Error opening PCM
device hw:1: No such device
Oct  1 05:19:09 scrappy pulseaudio[2037]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:1
sink_name=alsa_output.pci_1039_7012_alsa_playback_0"): initialization failed.
Oct  1 05:19:09 scrappy pulseaudio[2037]: module-alsa-source.c: Error opening
PCM device hw:1: No such device
Oct  1 05:19:09 scrappy pulseaudio[2037]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:1
source_name=alsa_input.pci_1039_7012_alsa_capture_0"): initialization failed.
Oct  1 05:19:09 scrappy pulseaudio[2037]: module-alsa-sink.c: Error opening PCM
device hw:0: No such device
Oct  1 05:19:09 scrappy pulseaudio[2037]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_1102_7_alsa_playback_0"): initialization failed.
Oct  1 05:19:09 scrappy pulseaudio[2037]: module-alsa-source.c: Error opening
PCM device hw:0: No such device
Oct  1 05:19:09 scrappy pulseaudio[2037]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_1102_7_alsa_capture_0"): initialization failed.
Comment 16 Lennart Poettering 2007-10-02 18:40:29 EDT
This seems to be an ALSA borkage. Please check if you have fragment in
/etc/modprobe.d that maps fixed indexes to sound drivers. If so, remove that
fragment.
Comment 17 Mike Chambers 2007-10-02 23:59:44 EDT
Created attachment 214301 [details]
modprobe.conf.dist file
Comment 18 Mike Chambers 2007-10-03 00:01:37 EDT
Not sure on this fragment stuff.  The only things I see in /etc/modprobe.d/ is 2
blacklist files and the modprobe.conf.dist file that I attached.  Hope this
helps.  BTW, I did a fresh rawhide install this morning, and sound (except
sound-detection) didn't work right off the bat.
Comment 19 Mike Chambers 2007-10-08 09:26:21 EDT
After turning on Consolekit and a reboot, my sound now works, and my cdroms were
detected by k3b.  Maybe this might help the others?
Comment 20 David Zeuthen 2007-10-09 11:19:45 EDT
Why did you turn off ConsoleKit in the first place? You must have done so
manually because it adds itself to runlevels 345 by default...
Comment 21 Mike Chambers 2007-10-10 09:30:36 EDT
(In reply to comment #20)
> Why did you turn off ConsoleKit in the first place? You must have done so
> manually because it adds itself to runlevels 345 by default...

Yes I did turn it off, as I turn off all services that I don't need, or think I
need.  I didn't know the intracacies of this service or I would had kept it on,
as I will now.  As below is the only explanation on the system-config-services
about it..

The ConsoleKit maintains a list of sessions (that's it). 

Note You need to log in before you can comment on or make changes to this bug.