Bug 290231 - APC Fencing Method "Switch (optional)" param does not default to "1"
APC Fencing Method "Switch (optional)" param does not default to "1"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 18:56 EDT by Paul Kennedy
Modified: 2015-04-19 20:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:51:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Kennedy 2007-09-13 18:56:38 EDT
Description of problem:
Used Conga to configure a cluster. When configuring APC fencing method, leaving
the "Switch (optional)" blank does not default to switch="1". When "Switch
(optional)" is left blank, the cluster.conf file contains no switch="1"
parameter. This causes the fencing to hang. Entering a value in "Switch
(optional)" adds a switch="<n>" parameter.

At first this appeared to be a Conga problem; however it looks like it is a
fence_apc problem. As part of troubleshooting, we used this command first:
fence_apc -a 10.15.90.32 -l apc -p apc -n 1 -v

It did not work.

Running it with the switch number as follows did work:
fence_apc -a 10.15.90.32 -l apc -p apc -n 1:1 -v

Version-Release number of selected component (if applicable):
kernel-2.6.18-36.el5
luci-0.10.0-6.el5
ricci-0.10.0-6.el5
modcluster-0.10.0-5.el5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jim Parsons 2007-09-14 10:46:33 EDT
Is this one of your master switch plus units in MSP? I think it is defaulting to
'0' right now, which is obviously the problem. I will jump on this with a fix
today, but please confirm that this is a MSP in Msp that this occurring on ;-)
Comment 3 RHEL Product and Program Management 2008-09-23 12:12:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2009-01-20 16:51:43 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Note You need to log in before you can comment on or make changes to this bug.