Bug 290291 - yum unable to get ANY updates from RHN - "Header is not Complete"
yum unable to get ANY updates from RHN - "Header is not Complete"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 20:04 EDT by paulp
Modified: 2008-09-26 17:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 17:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.conf (285 bytes, text/plain)
2007-09-17 23:34 EDT, paulp
no flags Details
up2date config file (1.25 KB, text/plain)
2007-09-17 23:40 EDT, paulp
no flags Details

  None (edit)
Description paulp 2007-09-13 20:04:35 EDT
Description of problem:
yum update fails with error "Header is not complete."


Version-Release number of selected component (if applicable):
yum-metadata-parser-1.0-8.fc6
yum-3.0.1-5.el5
yum-rhn-plugin-0.4.3-1.el5
yum-updatesd-3.0.1-5.el5


How reproducible:
fails every time

Steps to Reproduce:
1.'yum update'
2.
3.
  
Actual results:

[root@greenie ~]# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.4 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 846 kB    00:08     
################################################## 2501/2501
primary.xml.gz            100% |=========================| 6.7 kB    00:00     
################################################## 34/34
primary.xml.gz            100% |=========================|  25 kB    00:00     
################################################## 349/349
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for vim-minimal to pack into transaction set.
vim-minimal-7.0.109-3.el5 100% |=========================|  591 B    00:00     
Error: failed to retrieve getPackage/vim-minimal-7.0.109-3.el5.3.i386.rpm from
rhel-i386-server-5
error was [Errno -1] Header is not complete.



Expected results:
a listing of all available updates for download

Additional info:

I received a RHN Errata alert today for the kernel I am using but I am unable to
download it until yum is working!!!
Comment 1 James Antill 2007-09-14 00:59:51 EDT
 Are you going through a proxy, does this happen consistently?
 Can you download the files directly from RHN?

 Are you running yum-updatesd?

 You could try running with yum debugging turned on to see what else it might
say, but it looks like a network error to me ... so you'll probably need to get
a full network dump as the problem happens, and that will probably point
somewhere else.

 Why aren't putting this through your normal support channel?
Comment 2 paulp 2007-09-17 23:34:38 EDT
Created attachment 198021 [details]
yum.conf
Comment 3 paulp 2007-09-17 23:35:41 EDT
I think I am (trying to) go through the RHN proxy - where is that 
configured? /etc/sysconfig/rhn/up2date?

Yes yum-updatesd is running.

"Normal support channel"? As far as I know I just have web-based support. I 
thought this was it? How else can I get support?
Comment 4 paulp 2007-09-17 23:40:51 EDT
Created attachment 198041 [details]
up2date config file
Comment 5 James Antill 2007-09-18 09:44:19 EDT
 You want to login at:

 https://www.redhat.com/support/

...after which it should be obvious how to create a support ticket. After you
get a support ticket, mention this BZ and it should help it along.
Comment 6 paulp 2007-10-28 19:35:28 EDT
This bug was resolved by upgrading the upline RHN Proxy server from v4.1 to v4.2

This error was only present on RHEL5 hosts trying to update via the proxy 
server (all earlier versions of RHEL still worked).
Comment 7 James Antill 2008-09-26 17:11:58 EDT
This was fixed by the 5.2 errata, 3.2.8 ... because yum no longer requests header info. now.

Note You need to log in before you can comment on or make changes to this bug.