Bug 29030 - Filesystem crashes after remounting root fs several times
Filesystem crashes after remounting root fs several times
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Stephen Tweedie
Aaron Brown
none
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 09:26 EST by Philippe Lamalice
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-03 06:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philippe Lamalice 2001-02-23 09:26:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)


After mounting the root file system a couple of times (i would say over 10 
times), it crashes on boot-up, i get an incredible amount of errors 
reported by fsck and get dropped to admin shell. I re-installed fisher 3 
times and it did the same the 3 times

Reproducible: Always
Steps to Reproduce:
1.Install RH
2.Re-boot about 10 times
3.Crash
	

Actual Results:  The fs crashes :(

Expected Results:  It should not :P

Well, i'd like to have more infos but i just can't use the system 
afterwards, all logs are gone many files are missing... A big mess...
Comment 1 Michael K. Johnson 2001-02-23 14:19:32 EST
Could you please describe the hardware in your machine?  In particular,
I'd like to know whether you use IDE or SCSI, and if IDE, which chipset
you have, and if you use SCSI, which SCSI controller you have.

Thanks!
Comment 2 Glen Foster 2001-02-23 16:55:39 EST
We (Red Hat) should really try to resolve this before next release.
Comment 3 Philippe Lamalice 2001-02-24 08:21:30 EST
This is my hardware :

ASUS A7V MotherBoard (VIA Appolo KT133 Chipset)
ThunderBird 1100Mhz CPU
ATI Rage128 32MB DDR AGP
Creative SB Live! Value2.0
Fujitsu 20.4GB IDE (HD is ATA/100 but running ATA/66)
Floppy :P
Creative 52X IDE CD-Rom
D-Link DFE538-TX PCI Network (RTL8139 Based)
Digital DC21140 PCI Network (Tulip)
256MB SDRAM PC-133
Latest ASUS BIOS (1005D)
Note: I have a Promise Ultra ATA/100 Controller on-board but im not using it 
since Linux didn't support it (does fisher?)

That's about all..
Hope it may be of some help

Comment 4 Philippe Lamalice 2001-02-24 08:28:11 EST
Note : I forgot to mention that the 3rd time I installed fisher, i changed my 
drive for a Maxtor 30.7G i took from another of my computers... so obviously, 
my HD is not the cause... (and Windows and QNX wich resides on seperate 
partitions never had any problems)
Comment 5 Stephen Tweedie 2001-02-25 08:50:07 EST
A few questions:

When you say "reboot", are you talking about clean shutdown/reboot, or a hard
reboot such as /sbin/reboot -f, pressing the reset button or doing a power cycle?

Secondly, do you have an example of the log messages when the error happens, and
are there any disk controller messages amongst the filesystem messages?

Finally, has this hardware been stable under older versions of the kernel?
Comment 6 Philippe Lamalice 2001-02-26 05:51:32 EST
Yes, I'm talking about a clean reboot using reboot (or poweroff for a cold 
reboot)

I don't have the logs, they get deleted or unreadable when the fs crahses
(Essentially, fsck gives me a HUGE list of addreses on the ext2 fs that is 
corrupted)

And finally, nope, my controller has not had any problems with previous kernels
Comment 7 Stephen Tweedie 2001-02-26 06:29:15 EST
Can you try this with a Wolverine kernel to see if that makes any difference?
You don't need to upgrade any of the other components.  Email me at
sct@redhat.com if you need a hand getting the new kernel up.

Comment 8 Philippe Lamalice 2001-02-26 18:32:17 EST
Okay, i just re-installed fisher and downloaded the wolverine kernel from 
ftp.redhat.com. I updated the kernel with the new one. The system looks fine. I 
added a line to the rc.local file to reboot the computer, so the OS will go on 
an infinite reboot loop :P

I'll check on it times to times to see if it crashes again with the new kernel.
Comment 9 Philippe Lamalice 2001-03-03 06:14:38 EST
Ok, I was away for the last few days and left the computer running in it's 
infinite reboot loop. Fine! The system has not crashed yet :P

Note You need to log in before you can comment on or make changes to this bug.