Bug 290321 - X driver for radeon X800XL resolution regression
X driver for radeon X800XL resolution regression
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 21:12 EDT by Michael Wiktowy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 04:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf after booting from LiveCD (577 bytes, application/octet-stream)
2007-09-14 15:23 EDT, Michael Wiktowy
no flags Details
Xorg.0.log after booting from F8test2 LiveCD (65.21 KB, text/plain)
2007-09-14 15:32 EDT, Michael Wiktowy
no flags Details
Xorg.0.log after removing the xorg.conf and restarting X on F8test2 LiveCD (69.07 KB, application/octet-stream)
2007-09-14 15:57 EDT, Michael Wiktowy
no flags Details

  None (edit)
Description Michael Wiktowy 2007-09-13 21:12:34 EDT
Description of problem:
I have used the LiveCD of F7 and installed F7 on this machine (Radeon X800XL
(R430) video card with Syncmaster 900p monitor) and it chose an appropriate
resolution for this system automatically with no user intervention in xorg.conf.

The LiveCD (i686) of F8test2 does not. It picks 800x600 and gives the user no
other choice even if the monitor model is manually selected in the
system-config-display and the X server restarted.

Version-Release number of selected component (if applicable):
F8test2 i686 LiveCD

Additional info:
I picked the xorg-x11-drv-ati component to report against since there didn't
seem to be an xorg-x11-drv-radeon component.
Comment 1 Matěj Cepl 2007-09-14 08:19:16 EDT
Thanks for the bug report. Yes, you are correct -- there is no
xorg-x11-drv-radeon component, because radeon is just an another name for the
ati driver. We have reviewed the information you have provided above, and there
is some additional information we require that will be helpful in our diagnosis
of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Michael Wiktowy 2007-09-14 15:23:31 EDT
Created attachment 196131 [details]
xorg.conf after booting from LiveCD
Comment 3 Michael Wiktowy 2007-09-14 15:32:19 EDT
Created attachment 196141 [details]
Xorg.0.log after booting from F8test2 LiveCD
Comment 4 Michael Wiktowy 2007-09-14 15:37:33 EDT
There is another regression with this card where 3D Effects no longer work where
there works fine with F7. I reported it against compiz in Bug 290331 but maybe
should have reported it against the driver. Putting in a cross reference here so
that it gets the correct eyeballs on it:
https://bugzilla.redhat.com/show_bug.cgi?id=290331
Comment 5 Michael Wiktowy 2007-09-14 15:57:32 EDT
Created attachment 196171 [details]
Xorg.0.log after removing the xorg.conf and restarting X on F8test2 LiveCD
Comment 6 Michael Wiktowy 2007-09-14 16:00:48 EDT
I noticed when looking at the X log that I submitted, it properly identifies my
card model but it seems that the only X800XL listed is the PCIe version where
mine is in an AGP 8X slot. It may not be relevant but I thought it worth mentioning.
Comment 7 Dave Airlie 2007-09-25 20:15:03 EDT
Can you try the latest radeon driver in Rawhide? I think we've fixed this, it
was making TV out more important than VGA so limiting things to 800x600...
Comment 8 Michael Wiktowy 2007-09-25 22:23:58 EDT
Is there a Rawhide LiveCD spin? If not, I can probably scrounge up a extra HD to
try Rawhide on when I get a little time.
Comment 9 Michael Wiktowy 2007-09-25 22:57:07 EDT
I spoke too soon. Did your improved radeon driver make it into the
rawhide-20070925 LiveCD that Jeremy just announced?
Comment 10 Michael Wiktowy 2007-09-26 22:36:06 EDT
I can confirm that the radeon driver included in the rawhide-20070925 picks a
much better resolution (not the highest possible but much better than 800x600
and at least the highest is an option) and, in fact, correctly culls out a bunch
of inappropriate widescreen resolutions that F7 showed as options.

It also does the compiz stuff even better.

Thanks for your hard work.
Comment 11 Matěj Cepl 2007-09-27 04:28:00 EDT
Closing per reporter's comment 10. Thanks for collaboration.

Note You need to log in before you can comment on or make changes to this bug.