Bug 290501 - Like to see a right-click edit option for found networks in the networkmanager applet.
Like to see a right-click edit option for found networks in the networkmanage...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 03:43 EDT by Dave Stikkolorum
Modified: 2008-04-10 16:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 16:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Stikkolorum 2007-09-14 03:43:40 EDT
Description of problem:
I would like to see a right-click edit option for found networks
in the networkmanager applet.
This would be much more friendlier than add it with 'connect to other network' 
because that is inconsequent.

My experience is with wireless.

Version-Release number of selected component (if applicable):
NetworkManager applet 0.6.5

How reproducible:

Steps to Reproduce:
-left-click on network manager icon in screen.
-then you see the list of found networks
-then it would be nice to have a right-click edit option
that opens the 'connect to other networks'  config screen
and fills in all known info about that network if it is 
already present. Or if it is not: only the networkname.

  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2007-09-14 03:49:35 EDT
I think this might need some more explanation. Dave is a college of mine who is
using Fedora 7 on his laptop. When he wants to connect to our university network
he needs todo:
1) add other wireless network
2) Fill in name (which is visible already in the network list after a left click
   on the applet)
3) Select enterprise wpa as type
4) Fill in other details

This is anything but userfriendly, either the password popup which he gets when
he clicks on the network in the list needs a way to set enterprise wpa settings
and/or a right click should give a context menu with a properties menu-entry
which would take on to the add-other-network dialog with all already known
details filled in.
Comment 2 Dan Williams 2008-02-11 22:45:44 EST
FYI, connection editors are now upstream on both trunk (enabled in F8 & rawhide)
and stable (will get back to F7 in the 0.6.6 update soon)
Comment 3 Dan Williams 2008-04-10 16:49:57 EDT
Enabled in 0.6.6 which is in f7 updates.

Note You need to log in before you can comment on or make changes to this bug.