Bug 290661 - Mailman should use relative symlink in /etc/smrsh
Mailman should use relative symlink in /etc/smrsh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mailman (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 07:32 EDT by Milan Kerslager
Modified: 2013-04-15 04:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: mailman-2.1.9-5.el5
Doc Type: Bug Fix
Doc Text:
Previously, the /etc/smrsh/mailman symbolic link used an absolute path, which may have not work properly in a chroot environment. This error has been fixed, and the symbolic link now uses a relative path.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 11:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2007-09-14 07:32:07 EDT
Mailman shoud use relative symlink in /etc/smrsh:

cd /etc/smrsh
ln -s ../../usr/lib/mailman/mail/mailman
Comment 1 Tomas Smetana 2007-09-18 02:41:27 EDT
Mailman creates the symlink during installation since 2.0 beta 5 (according to
the changelog) and on all the systems in reach I can see it's there.
Comment 2 Tomas Smetana 2007-10-16 10:29:30 EDT
What version of Mailman doesn't create the link for you?
Comment 3 Tomas Smetana 2007-11-28 08:08:33 EST
No answer => closing.
Comment 4 Milan Kerslager 2007-11-29 15:31:17 EST
Mailman shoud use relative symlink in /etc/smrsh instead of absolute link.

Absolute link does not work with chroot (aka Anaconda, rescue mode etc).
Comment 5 Tomas Smetana 2007-11-30 02:46:33 EST
Oh my... I didn't read the bugreport carefully enough.  Sorry.  You're right of
course.
Comment 7 RHEL Product and Program Management 2008-07-21 19:09:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 Jaromir Hradilek 2010-09-21 09:52:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the /etc/smrsh/mailman symbolic link used an absolute path, which may have not work properly in a chroot environment. This error has been fixed, and the symbolic link now uses a relative path.
Comment 15 errata-xmlrpc 2010-09-29 11:52:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0726.html

Note You need to log in before you can comment on or make changes to this bug.