Bug 290681 - xmaxima is not working, jfa: starting server on port 4008 couldn't open socket:
xmaxima is not working, jfa: starting server on port 4008 couldn't open socket:
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: maxima (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 08:05 EDT by Antonio A. Olivares
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 18:10:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio A. Olivares 2007-09-14 08:05:41 EDT
Description of problem:
xmaxima or maxima-gui fails to start.  


Version-Release number of selected component (if applicable):
Maxima 5.13.0 http://maxima.sourceforge.net


How reproducible:
Start xmaxima from Menu 


Steps to Reproduce:
1.  Just click on xmaxima from gnome/kde
2.  maxima fails to start
3.
  
Actual results:
[olivares@localhost ~]$ rpm -qf `which xmaxima`
maxima-gui-5.13.0-4.fc6
[olivares@localhost ~]$ xmaxima
Maxima 5.13.0 http://maxima.sourceforge.net
Using Lisp GNU Common Lisp (GCL) GCL 2.6.7 (aka GCL)
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
This is a development version of Maxima. The function bug_report()
provides bug reporting information.
(%i1) [olivares@localhost ~]$ 


Expected results:
xmaxima was working fine.  maxima(CLI) works fine only gui is failing.  

[olivares@localhost ~]$ maxima
Maxima 5.13.0 http://maxima.sourceforge.net
Using Lisp GNU Common Lisp (GCL) GCL 2.6.7 (aka GCL)
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
This is a development version of Maxima. The function bug_report()
provides bug reporting information.
(%i1) solve(x^2-2*x-1=0,x);
(%o1)                 [x = 1 - sqrt(2), x = sqrt(2) + 1]
(%i2) quit();
[olivares@localhost ~]$  


Additional info:
If you need more info please let me know.

[olivares@localhost ~]$ rpm -qa maxima*
maxima-5.13.0-4.fc6
maxima-gui-5.13.0-4.fc6
maxima-runtime-gcl-5.13.0-4.fc6
Comment 1 Rex Dieter 2007-09-14 08:17:35 EDT
What version of wxMaxima $(rpm -q wxMaxima) ?
Comment 2 Rex Dieter 2007-09-14 08:18:31 EDT
And what arch (i386, x86_64, ...)?
Comment 3 Rex Dieter 2007-09-14 08:21:56 EDT
nevermind about wxMaxima, you're not using that... :)
Comment 4 Rex Dieter 2007-09-14 08:24:38 EDT
regardless, I'd recommend you do try wxMaxima, it's a much nicer gui than xmaxima
Comment 5 Antonio A. Olivares 2007-09-14 18:13:48 EDT
[olivares@localhost ~]$ uname -iprm
2.6.22.4-45.fc6 i686 i686 i386
[olivares@localhost ~]$ su -
Password: 
[root@localhost ~]# yum install wxMaxima
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core                      100% |=========================| 1.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for wxMaxima to pack into transaction set.
wxMaxima-0.7.2-1.fc6.i386 100% |=========================| 6.5 kB    00:00     
---> Package wxMaxima.i386 0:0.7.2-1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libwx_baseu_xml-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_qa-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) for package:
wxMaxima
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_baseu-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_baseu_net-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6) for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6) for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6) for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0 for package: wxMaxima
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0 for package: wxMaxima
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for wxGTK to pack into transaction set.
wxGTK-2.6.3-2.6.3.2.3.fc6 100% |=========================|  24 kB    00:00     
---> Package wxGTK.i386 0:2.6.3-2.6.3.2.3.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 wxMaxima                i386       0.7.2-1.fc6      extras            524 k
Installing for dependencies:
 wxGTK                   i386       2.6.3-2.6.3.2.3.fc6  extras            3.5 M

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 4.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): wxMaxima-0.7.2-1.f 100% |=========================| 524 kB    00:00     
(2/2): wxGTK-2.6.3-2.6.3. 100% |=========================| 3.5 MB    00:01     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: wxGTK                        ######################### [1/2] 
  Installing: wxMaxima                     ######################### [2/2] 

Installed: wxMaxima.i386 0:0.7.2-1.fc6
Dependency Installed: wxGTK.i386 0:2.6.3-2.6.3.2.3.fc6
Complete!

I have installed wxMaxima and it does not work either.


[root@localhost ~]# wxmaxima 

** (wxmaxima:4474): WARNING **: IPP request failed with status 1030

When I try to do something, wxmaxima returns

Not connected to maxima!


At home, I have another FC6 machine without updates and maxima,and xmaxima work
without problems.  I put only kernel updates on that machine.

Thanks,

Antonio 
Comment 6 Rex Dieter 2007-10-11 09:37:22 EDT
See also bug #322171
Please double-check that your /etc/hosts entry for localhost exists and is 
correct.
Comment 7 Antonio A. Olivares 2007-10-14 21:08:00 EDT
Rex,

sorry for not responding earlier, but the machine which had the problem, I
decided to install Rawhide.  I am no longer having that problem.  I have another
fc6 machine at home which maxima is working fine without the updates, maxima is
at 5.12.  What can I do to help?  At home I am on dialup and updating it will
take a long time plus fedora core 6 is almost end of line, so I am in the middle
of a problem.  I am sorry to cause problems, what should I do?

at home the machine has the localhost.localdomain and 127.0.0.1 hosts but it did
not have this problem.  It only happened on the fedora core 6 machine which
became a rawhide machine.  

Thanks,

Antonio  
Comment 8 Rex Dieter 2007-11-11 18:10:27 EST
Looks like it was most likely /etc/hosts, localhost at issue here.

If you can still reproduce the problem, feel free to reopen with any new details.

Note You need to log in before you can comment on or make changes to this bug.