Bug 29088 - qla2x00 module will not unload
qla2x00 module will not unload
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 29732 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 11:50 EST by Michael E Brown
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 17:28:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael E Brown 2001-02-23 11:50:29 EST
an 'rmmod qla2x00' will hang indefinetly. When an 'lsmod' is performed, the
qla2x00 module is listed as '(deleted)'
Comment 1 Michael E Brown 2001-02-23 11:54:11 EST
the line from 'lsmod' is as follows:

module		size	used	by
qla2x00 		0 	0	(deleted)
Comment 2 Arjan van de Ven 2001-02-23 12:41:22 EST
Is there an oops in dmesg ?
if so, please type dmesg | ksymoops
Comment 3 Michael E Brown 2001-02-23 12:54:33 EST
There is no oops or anything in 'dmesg'. There is nothing in /var/log/messages. 

After this, you cannot reload the qla2x00 driver at all...
'modprobe qla2x00'  will return immediately, but does not change the state of
the system.
Comment 4 Glen Foster 2001-02-23 16:55:16 EST
We (Red Hat) should really try to resolve this before next release.
Comment 5 Karsten Hopp 2001-02-27 13:44:05 EST
*** Bug 29732 has been marked as a duplicate of this bug. ***
Comment 6 Michael E Brown 2001-03-06 11:13:24 EST
Still present in RC2.  kernel 2.4.2-0.1.19
Comment 7 Matt Wilson 2001-03-06 17:28:40 EST
I believe we have a patch in the pipeline.
Comment 8 Michael K. Johnson 2001-03-12 14:12:55 EST
Please test 2.4.2-0.1.22 or later, and re-open this report if the
bug is not fixed.

Note You need to log in before you can comment on or make changes to this bug.