Bug 290921 - Using noatime ext3 parameter in fstab causes rhgb boot delay
Using noatime ext3 parameter in fstab causes rhgb boot delay
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 10:53 EDT by Gary Yuen
Modified: 2008-01-21 02:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 02:50:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Yuen 2007-09-14 10:53:30 EDT
Description of problem:

When I use the noatime mount parameter to mount my ext3 partitions in fstab, there's a several minute 
delay before rhgb comes up. All I see is a busy mouse cursor and a blank screen.

Version-Release number of selected component (if applicable):

0.17.6

How reproducible:

always

Steps to Reproduce:
1. Edit fstab and add noatime mount parameter to ext3 partitions.
2. Reboot
  
Actual results:

When rhgb startups, it shows a busy mouse cursor and blank screen for several minutes before the 
normal boot progress screen shows up.
Comment 1 Ray Strode [halfline] 2007-09-14 11:07:39 EDT
Hi,

RHGB never looks at the atime of any files (or even stats files at all for that
matter).  RHGB /will/ wait for the X server to to tell it "I'm ready for
connections" before continuing.  It could be the X server is depending on atime
for some reason.

if you do 
/sbin/init 3

and then

startx

does that also take several minutes?
Comment 2 Gary Yuen 2007-09-15 08:01:55 EDT
After /sbin/init 3, x comes up immediately. If I also remove rhgb quiet from the kernel parameters, x also 
comes up immediately using noatime. I'm not sure if it's specifically noatime or something else. I do know 
when I remove noatime, then I don't have the rhgb delay. 

I also have most services disabled but I'm not sure if that would matter.
Comment 3 Gary Yuen 2007-09-15 10:53:27 EDT
I might have narrowed it down. I've also modified

/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules

to make the following change:

"/usr/lib/gtk-2.0/immodules/im-scim.so" 
"scim" "SCIM Input Method" "scim" "/usr/share/locale" "ja:ko:zh:de:fr:en" 

This lets SCIM come up in my default language instead of just ja, ko, and zh.  It seems that is the real 
cause although I had though it was the noatime change. I had tested that before.

I'm not sure if the above change is the proper way to let SCIM be available in any language.

Comment 4 Ray Strode [halfline] 2007-09-17 10:22:48 EDT
I'm guessing this is a SCIM bug, although I don't know for sure.

I'm going to reassign it to SCIM, but Jens, feel free to bounce it back to me if
rhgb needs to do anything differently (or if it just doesn't seem like a SCIM bug).



Comment 5 Jens Petersen 2007-09-17 22:47:13 EDT
(In reply to comment #3)
> This lets SCIM come up in my default language instead of just ja, ko, and zh.
 It seems that is the real 
> cause although I had though it was the noatime change. I had tested that before.
> 
> I'm not sure if the above change is the proper way to let SCIM be available in
any language.

No, the right way to turn on SCIM is to use the im-chooser tool.

We do not recommend running scim or input methods by default for all gtk.
Comment 6 Gary Yuen 2007-09-19 13:12:14 EDT
Then I'm not sure how my modification of gtk.immodules is different from if I used an Asian language by 
default. The rhgb delay does btw happen when the system language is Chinese. I imagine it happens with 
jp and ko as well. 
Comment 7 Jens Petersen 2007-09-19 23:37:53 EDT
Because using "ja:ko:zh:de:fr:en" or "*" instead of "" (what we have in Fedora)
means scim will always run for any gtk application, which includes
rhgb and gdm etc, which is a bad idea IMHO.

Instead if you use ~/.xinputrc (which im-chooser creates) scim will only
start on the desktop not before.
Comment 8 Jens Petersen 2007-11-07 23:01:30 EST
I would like to close this bug - do you still think there is an issue?

Note You need to log in before you can comment on or make changes to this bug.