Bug 29103 - Rdate prints/sets incorrect date when the hardware clock is set to localtime.
Rdate prints/sets incorrect date when the hardware clock is set to localtime.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rdate (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 13:07 EST by Need Real Name
Modified: 2015-03-04 20:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-16 11:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-23 13:07:09 EST
When using rdate to print the time or to set the system time, it only works
if the hardware (BIOS) clock is set to GMT.  When the hardware clock is set
to localtime (CST, or GMT-6), the time printed or set is 12 hours into the
future.  It is important that the hardware clock be set to localtime,
because I am running Windows 98 inside of VMware for Linux, and Windows 98
requires that the hardware clock be set to localtime, or else Windows 98
displays a time 12 hours into the future.
Comment 1 Phil Knirsch 2001-06-16 11:36:42 EDT
According to RFC 868 which specifies the rdate protocol and behaviour the time
has to be in GMT, at least from the server.

A possibility would be to add another option to rdate, e.g. -l, in order to tell
the client to set/print in localtime rather than in GMT.

Read ya, Phil
Comment 2 Phil Knirsch 2001-08-23 06:23:12 EDT
Changing to defered now as there are currently a lot of other pressing matters
that i need to take care of first.

I'll finally close this bug when i get time to do this RFE.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.