Bug 291061 - selinux stops everything working in runlevel 1
selinux stops everything working in runlevel 1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 291021 291031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 11:36 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 14:19:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-09-14 11:36:56 EDT
I think everything seems to be broken actually.

# /etc/init.d/network restart
Permission denied
# setenforce 0
# /etc/init.d/network restart
Shutting down loopback interface (etc..)
Comment 1 Need Real Name 2007-09-14 11:52:21 EDT
Same for sshd, smolt, etc. etc.
Comment 2 Need Real Name 2007-09-14 12:07:54 EDT
It seems the problem is only present in runlevel 1.
Comment 3 Need Real Name 2007-09-14 12:08:11 EDT
*** Bug 291031 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2007-09-14 12:12:32 EDT
*** Bug 291021 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2007-09-14 13:41:46 EDT
How did you get to runlevel 1?  What context are you running while there?

id -Z

If you login by executing sulogin 
does it fix the problem.
Comment 6 Need Real Name 2007-09-16 10:04:39 EDT
How did I get to runlevel 1?
By appending " 1" to the end of the grub boot line.

# id -Z
system_u:system_r:sysadm_t:s0

# sulogin
Permission denied.

(I may be slow to respond due to bug 291181)
Comment 7 Daniel Walsh 2007-09-21 14:19:56 EDT
Fixed in selinux-policy-3.0.8-5.fc8

Note You need to log in before you can comment on or make changes to this bug.