Bug 291231 - crash in gtk_style_realize
crash in gtk_style_realize
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 12:41 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:46:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-09-14 12:41:31 EDT
Description of problem:

firefox crashed. Don't recall what I was doing - perhaps closing a tab?

Version-Release number of selected component (if applicable):

firefox-2.0.0.6-8.fc8

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912589753616 (LWP 1177)]
0x00002aaaac0a324c in gtk_style_realize (style=0x14afeb0, colormap=0x0)
    at gtkstyle.c:840
840       style->depth = gdk_colormap_get_visual (colormap)->depth;
#0  0x00002aaaac0a324c in gtk_style_realize (style=0x14afeb0, colormap=0x0)
    at gtkstyle.c:840
#1  0x00002aaaac0a7557 in IA__gtk_style_attach (style=0x64f82d0, 
    window=0x6421a0) at gtkstyle.c:753
#2  0x00002aaaac1509d5 in gtk_widget_set_style_internal (widget=0x7fcc40, 
    style=0x64f82d0, initial_emission=0) at gtkwidget.c:6016
#3  0x00002aaaac150b68 in reset_rc_styles_recurse (widget=0x7fcc40, 
    data=<value optimized out>) at gtkwidget.c:6230
#4  0x00002aaab651f653 in moz_container_forall (
    container=<value optimized out>, include_internals=<value optimized out>, 
    callback=0x2aaaac150af0 <reset_rc_styles_recurse>, callback_data=0x0)
    at mozcontainer.c:401
#5  0x00002aaaac0714e4 in gtk_rc_reset_widgets (settings=0x620000)
    at gtkrc.c:1629
#6  0x00002aaaac071695 in _gtk_rc_context_get_default_font_name (
    settings=0x620000) at gtkrc.c:1727
#7  0x00002aaaac0a32a1 in _gtk_style_init_for_settings (style=0x6983220, 
    settings=0x0) at gtkstyle.c:383
#8  0x00002aaaac0ac88d in gtk_style_init (style=0x6983220) at gtkstyle.c:410
#9  0x0000003bbac29c31 in IA__g_type_create_instance (
    type=<value optimized out>) at gtype.c:1561
#10 0x0000003bbac119ed in g_object_constructor (type=4, 
    n_construct_properties=0, construct_params=0x40) at gobject.c:1046
#11 0x0000003bbac0f824 in IA__g_object_newv (object_type=8171296, 
    n_parameters=0, parameters=0x0) at gobject.c:937
#12 0x0000003bbac1026c in IA__g_object_new_valist (object_type=8171296, 
    first_property_name=0x0, var_args=0x7fff59a319e0) at gobject.c:986
#13 0x0000003bbac104a1 in IA__g_object_new (object_type=8171296, 
    first_property_name=0x0) at gobject.c:795
#14 0x00002aaab6ff5549 in __cxa_pure_virtual ()
   from /usr/lib64/gtk-2.0/2.10.0/engines/libnodoka.so
#15 0x00002aaaac0724f5 in gtk_rc_init_style (context=0x7c26d0, 
    rc_styles=0xf0f700) at gtkrc.c:2376
#16 0x00002aaaac072985 in IA__gtk_rc_get_style (widget=<value optimized out>)
    at gtkrc.c:2017
#17 0x00002aaaac150ace in gtk_widget_reset_rc_style (widget=0x7f42e0)
    at gtkwidget.c:5626
#18 0x00002aaaac150b68 in reset_rc_styles_recurse (widget=0x7f42e0, 
    data=<value optimized out>) at gtkwidget.c:6230
#19 0x00002aaaac0714e4 in gtk_rc_reset_widgets (settings=0x620000)
    at gtkrc.c:1629
#20 0x00002aaaac07622e in IA__gtk_rc_reparse_all_for_settings (
    settings=<value optimized out>, force_load=1) at gtkrc.c:1826
#21 0x0000003bbac0b169 in IA__g_closure_invoke (closure=0x7c3a50, 
    return_value=0x0, n_param_values=2, param_values=0x7fff59a31f40, 
    invocation_hint=0x7fff59a31e00) at gclosure.c:490
#22 0x0000003bbac1aa81 in signal_emit_unlocked_R (node=0x631d90, detail=326, 
    instance=0x620000, emission_return=0x0, instance_and_params=0x7fff59a31f40)
    at gsignal.c:2440
#23 0x0000003bbac1bed4 in IA__g_signal_emit_valist (instance=0x620000, 
    signal_id=<value optimized out>, detail=326, var_args=0x7fff59a321c0)
    at gsignal.c:2199
#24 0x0000003bbac1c0a3 in IA__g_signal_emit (instance=0x4, signal_id=0, 
    detail=64) at gsignal.c:2243
#25 0x0000003bbac0ef6f in g_object_dispatch_properties_changed (
    object=0x620000, n_pspecs=1, pspecs=0x7fff59a322d0) at gobject.c:563
#26 0x0000003bbac0f5c5 in IA__g_object_thaw_notify (object=0x620000)
    at gobjectnotifyqueue.c:123
#27 0x00002aaaac08f9ec in merge_color_scheme (settings=0x620000, 
    value=<value optimized out>, source=4) at gtksettings.c:2122
#28 0x00002aaaac091adf in _gtk_settings_handle_event (
    event=<value optimized out>) at gtksettings.c:1733
#29 0x00002aaaac0208ad in IA__gtk_main_do_event (event=0x4) at gtkmain.c:1385
#30 0x00002aaaac50072c in gdk_event_dispatch (source=<value optimized out>, 
    callback=<value optimized out>, user_data=<value optimized out>)
    at gdkevents-x11.c:2351
#31 0x0000003bba82ef13 in IA__g_main_context_dispatch (context=0x64a630)
    at gmain.c:2061
#32 0x0000003bba83220d in g_main_context_iterate (context=0x64a630, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2694
#33 0x0000003bba83251a in IA__g_main_loop_run (loop=0x1152ff0) at gmain.c:2898
#34 0x00002aaaac020d43 in IA__gtk_main () at gtkmain.c:1144
#35 0x00002aaab6528176 in nsAppShell::Run (this=0x803350) at nsAppShell.cpp:139
#36 0x00002aaab7213812 in nsAppStartup::Run (this=0x8032d0)
    at nsAppStartup.cpp:151
#37 0x00000000004086a0 in XRE_main (argc=0, argv=<value optimized out>, 
    aAppData=<value optimized out>) at nsAppRunner.cpp:2711
#38 0x00002aaaadd0ed34 in __libc_start_main (main=0x403a78 <main>, argc=1, 
    ubp_av=0x7fff59a33048, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff59a33038) at libc-start.c:220
#39 0x00000000004039c9 in _start ()
Comment 1 Bill Nottingham 2007-09-14 12:43:52 EDT
Actually, I was on anther workspace changing the icon theme - that may have
something to do with this.
Comment 2 Matthias Clasen 2007-09-14 15:48:41 EDT
Yeah, thats related
Comment 3 Matěj Cepl 2007-12-20 11:46:38 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.