Bug 291291 - yumex dies after partial update
Summary: yumex dies after partial update
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 8
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-14 17:28 UTC by Herbert Carl Meyer
Modified: 2008-08-02 23:40 UTC (History)
1 user (show)

Fixed In Version: fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-27 12:15:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Herbert Carl Meyer 2007-09-14 17:28:45 UTC
Description of problem:

yumex dies after partial update

Version-Release number of selected component (if applicable):

2.0.1

How reproducible:

100%

Steps to Reproduce:
1. run yumex partial update (pick some updates, not all)
2. let update complete, when quit-ok box appears, pick Ok to redisplay yumex
  
Actual results:
yumex dies, error message on console

Expected results:
yumex refreshes, redisplays update list

Additional info:

error message:

GLib-ERROR **: file gmain.c: line 2064 (g_main_dispatch): assertion failed:
(current->source == &current_source_link)
aborting...
/usr/share/yumex/yumex: line 5:  5602 Aborted                 /usr/bin/python
/usr/share/yumex/yumex.pyc $*

Comment 1 Tim Lauridsen 2007-09-28 10:24:56 UTC
I have tried a lot of times but i can't reproduce this error. :)



Comment 2 Bug Zapper 2008-04-04 13:50:31 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 3 Jan Hutař 2008-07-22 14:22:16 UTC
Hello,
could you please try to update your yumex? I think this could be already fixed 
- see bug 379731 (or maybe even bug 248158?)

Comment 4 Tim Lauridsen 2008-07-25 08:37:17 UTC
Herbert please comfim, the state of this issue, with the current version of yumex.

Comment 5 Herbert Carl Meyer 2008-07-27 12:15:47 UTC
Sorry about delay, this bug no longer exists. Kill it, please.

However I have a new one to file against fc10-rawhide.


Note You need to log in before you can comment on or make changes to this bug.