Bug 29137 - snmp problem with ethereal.0.8.15 and ucd-snmp-4.2-4 THIS IS NOT A RPM PROBLEM
snmp problem with ethereal.0.8.15 and ucd-snmp-4.2-4 THIS IS NOT A RPM PROBLEM
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 16:05 EST by Mike R. Cannon
Modified: 2015-03-04 20:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 14:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike R. Cannon 2001-02-23 16:05:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


I chose "rpm" for the problem type for lack of a better choice, sorry!
I am unable to install ethereal from soure without issuing ./configure --
disable-snmp.  I have been working with the ethereal developers on this 
issue.  They are telling me that it is a readhat snmp installation 
problem.  I have had this problem with fisher, and wolverine, but not with 
redhat 7.  I have since moved to the RPM instllation which is also 
problematic.

Reproducible: Always
Steps to Reproduce:
0. Perform wolverine, or fisher install with everything!

1.As root rpm -i ethereal-0.8.15-1.i386.rpm and receive:
Failed dependency
 "libsnmp.so.0 is needed by ethereal-0.8.15-1"

/usr/lib/libsnmp.so.0 is installed on the system and is a symbolic linke 
to /usr/lib/libsnmp-0.4.2.so

2.so then
As root rpm -i ucd-snmp-4.2-4.i386.rpm and receive:
failed dependency:
libbz2.so.0 is needed by ucd-snmp-4.2-4

3.so then
As root rpm -i --nodeps ucd-snmp-4.2-4.i386.rpm and receive:
package ucd-snmp-4.2-4 already installed



Actual Results:  I realy need to be able to install ethereal with snmp 
encrypted support on a redhat machine (newest version).

Expected Results:  If snmp is installed correctly as part of the fisher or 
wolverine complete "everything" install ethereal should install cleanly 
from an RPM or source.  And again the "everthing" redhat 7.0 install 
allows for the ethereal install to complete ok from rpm or source.


I am going to attach some email correcspndence from ethereal and myself:

***************************
first long email
***************************

It's my code to look for SSL. I may not have explained the purpose
particularly well. Doco never has been my strong point.

The patch to the configure process should apply cleanly to the 0.8.15
source, so I'll include it here.

--with-ssl=/path/to/ssl

(ie the dir containing include/ssl and lib/libcrypto.a) is what you need

The problem is that the test for ucd-snmp in the Ethereal ./configure won't
work if ucd-snmp was built with SSL or OpenSSL, but still leaves traces of
"I found ucd-snmp" in the Makefile.

Without my patch you either have to -disable-snmp or somehow add
"-I/path/to/ssl/includes/" to CFLAGS and "-L/path/to/ssl/lib -lcrypto" to
LDFLAGS


BUT.
The line "lrwxrwxrwx 1 root root 16 Feb 10 07:49 /usr/lib/libsnmp.so.0.4.2
->libsnmp-0.4.2.so" looks strange.

Is this a symlink pointing to itself? If it is you might have to uninstall
ucd-snmp, clean up the dangling symlinks, and reinstall.


Regards,
Andrew Hood
A distributed system is one in which the failure of a computer you didn't
even know existed can render your own computer unusable. -- Leslie Lamport,
as quoted in CACM, June 1992
 <<ethereal-0.8.15.patch>> 

-----Original Message-----
From: Guy Harris [mailto:guy@netapp.com]
Sent: Monday, 19 February 2001 13:10
To: Mike Cannon
Cc: ethereal-users@ethereal.com
Subject: Re: [Ethereal-users] make failure with redhat 7.0.90
"fisher"

> Here is the log and thanks again for your time.

configure:3822: checking for sprint_objid in -lsnmp
configure:3842: gcc -o conftest -Wall -g -O2 -I$(top_srcdir)
-I$(top_srcdir)/wiretap -I$(top_srcdir)/epan -I/usr/local/include
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/pcap
-I$(top_srcdir) -I$(top_srcdir)/wiretap -I$(top_srcdir)/epan
-I/usr/local/include -I/usr/include/pcap  -L/usr/local/lib conftest.c -
lsnmp

-lz  1>&5
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsnmp.so:
undefined
    reference to `EVP_DigestInit'
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsnmp.so:
undefined
    reference to `EVP_DigestFinal'

...

It looks as if this version of SNMP requires a crypto library of some
sort.  If it's an SSL library, then the next version of Ethereal will
either automatically look for the SSL library or will require you to
configure with "-with-ssl" on platforms where the SNMP library was built
to require the SSL library.  (I didn't write the SSL checking stuff, and
I don't remember which of those the person who did write it said it
does.)

For now, you will probably have to re-run configure with

--disable-snmp

and then rebuild.  This will cause Ethereal to dissect SNMP but will
cause it *NOT* to attempt to use the UCD SNMP library to more
symbolically dissect SNMP packets.

_______________________________________________
Ethereal-users mailing list
Ethereal-users@ethereal.com


***************************
another one coming
***************************
Mike,

Then I can't see what's wrong.

Two possibilities to get you up and running:
1 Run ./configure including the -with-ssl option in an unpatched source
tree. It might already support it.
2 Delete the duplicate definition macro from acinclude.m4. It should be at
the end.


How recent is your ethereal base code?
Is it possible the patches were already included? Guy sent me a mail saying
it was applied to CVS. From the CVS log it would be in any snapshots less
than a month old
Were there any rejects from the patch?
I would have heard complaints and someone would have removed it from CVS if
my patch caused problems.


If none of the above sort it out for you, please send me copies of
configure.in and acinclude.m4 from your source before and after you have
patched.


Regards,
Andrew Hood
IBM Global Services Australia
A distributed system is one in which the failure of a computer you didn't
even know existed can render your own computer unusable. -- Leslie Lamport,
as quoted in CACM, June 1992


-----Original Message-----
From: Mike Cannon [mailto:cannon@purdue.edu]
Sent: Wednesday, 21 February 2001 23:55
To: HOOD, Andy
Subject: Re: [Ethereal-users] make failure with redhat 7.0.90
"fisher"

now that I performed the patch installation and proper syntax for
the --with-ssl I get:
cd . && aclocal `./aclocal-flags`

aclocal: acinclude.m4: 399: duplicated macro `AC_ETHEREAL_SSL_CHECK'

make: *** [aclocal.m4] Error 1

--
Mike Cannon
Infrastructure Systems Administrator
Management Information
Purdue University
1061 Freehafer Hall (FREH)
West Lafayette, IN  47907-1061

office phone: 765.494.6357
office fax: 765.496.1380
email: cannon@purdue.edu
----- Original Message -----
From: "HOOD, Andy" <ahood@westpac.com.au>
To: "Mike Cannon" <cannon@purdue.edu>
Sent: Wednesday, February 21, 2001 1:22 AM
Subject: RE: [Ethereal-users] make failure with redhat 7.0.90 "fisher"


> Sorry Mike, didn't read all your mail.
>
> The patch needs to applied with patch. Something like
>
> cd /your/ethereal/dir
> patch < patchfilename
>
> You might need some other options but they vary with your version of
patch,
> so read the man page. The most likely error is "can't find". With GNU
patch
> the required option is -p0 or -p1.
>
>
> Then my previous reply should work.
>
> ./configure --with-ssl=/usr
>
>
> If you get ethereal from CVS Guy says this patch is already applied.
>
>
> Regards,
> Andrew Hood
> A distributed system is one in which the failure of a computer you didn't
> even know existed can render your own computer unusable. -- Leslie
Lamport,
> as quoted in CACM, June 1992
>
>
> -----Original Message-----
> From: Mike Cannon [mailto:cannon@purdue.edu]
> Sent: Wednesday, 21 February 2001 11:20
> To: HOOD, Andy; ethereal-users@ethereal.com
> Subject: Re: [Ethereal-users] make failure with redhat 7.0.90
> "fisher"
>
> Well I tried both:
> ./configure --with-ssl=/usr/lib
> and
> ./configure --with-ssl=/usr/lib/
>
> The path to libcrypto.a was /usr/lib/libcrypto.a
>
> Neither worked, same error.  How do you install the patch?  Just copy it
> into the directory?
>
> Since this is theoretically the next release of RedHat are you interested
in
> fixing the root problem?
> --
> Mike Cannon
> Infrastructure Systems Administrator
> Management Information
> Purdue University
> 1061 Freehafer Hall (FREH)
> West Lafayette, IN  47907-1061
>
> office phone: 765.494.6357
> office fax: 765.496.1380
> email: cannon@purdue.edu
> ----- Original Message -----
> From: "HOOD, Andy" <ahood@westpac.com.au>
> To: "Mike Cannon" <cannon@purdue.edu>; <ethereal-users@ethereal.com>
> Sent: Tuesday, February 20, 2001 12:12 AM
> Subject: RE: [Ethereal-users] make failure with redhat 7.0.90 "fisher"
>
>
> > Hmmm, yours is different to mine.
> >
> > I have (from memory, I can't check at the moment)
> > /usr/local/ssl/{include,lib}
> >
> > You should only need the one that points to the libcrypto.a
> >
> > You aren't trying to compile anything so you don't need the headers,
only
> > the lib.
> >
> >
> > Now, back to rebuilding Solaris ...
> >
> > Regards,
> > Andrew Hood
> > A distributed system is one in which the failure of a computer you
didn't
> > even know existed can render your own computer unusable. -- Leslie
> Lamport,
> > as quoted in CACM, June 1992
> >
> >
> > -----Original Message-----
> > From: Mike Cannon [mailto:cannon@purdue.edu]
> > Sent: Tuesday, 20 February 2001 11:26
> > To: HOOD, Andy; ethereal-users@ethereal.com
> > Subject: Re: [Ethereal-users] make failure with redhat 7.0.90
> > "fisher"
> >
> > again the --disable-snmp worked but I would like to get the patch
working.
> >
> > libsnmp.so, libsnmp.so.0, libsnmp.so.0.4.2 are symlinks to
> libsnmp-0.4.2.so
> >
> > OK, I started with a freshly untared ethereal and the put the patch 
Andy
> > sent me in the untared directory.
> >
> > I then ./configure --with-ssl=/usr/bin/openssl, which failed.  I reread
> the
> > directions and should the --with-ssl=
> > 1) /usr/include/openssl
> > and or
> > 2) /usr/lib/
> > Choice 2 contains a file named libcrypto.a
> >
> > Not sure what syntax to use for multiple directories?
> > --
> > Mike Cannon
> > Infrastructure Systems Administrator
> > Management Information
> > Purdue University
> > 1061 Freehafer Hall (FREH)
> > West Lafayette, IN  47907-1061
> >
> > office phone: 765.494.6357
> > office fax: 765.496.1380
> > email: cannon@purdue.edu
> > ----- Original Message -----
> > From: "HOOD, Andy" <ahood@westpac.com.au>
> > To: <ethereal-users@ethereal.com>
> > Cc: <cannon@purdue.edu>
> > Sent: Monday, February 19, 2001 12:10 AM
> > Subject: RE: [Ethereal-users] make failure with redhat 7.0.90 "fisher"
> >
> >
> > > It's my code to look for SSL. I may not have explained the purpose
> > > particularly well. Doco never has been my strong point.
> > >
> > > The patch to the configure process should apply cleanly to the 0.8.15
> > > source, so I'll include it here.
> > >
> > > --with-ssl=/path/to/ssl
> > >
> > > (ie the dir containing include/ssl and lib/libcrypto.a) is what you
need
> > >
> > > The problem is that the test for ucd-snmp in the Ethereal ./configure
> > won't
> > > work if ucd-snmp was built with SSL or OpenSSL, but still leaves
traces
> of
> > > "I found ucd-snmp" in the Makefile.
> > >
> > > Without my patch you either have to -disable-snmp or somehow add
> > > "-I/path/to/ssl/includes/" to CFLAGS and "-L/path/to/ssl/lib -
lcrypto"
> to
> > > LDFLAGS
> > >
> > >
> > > BUT.
> > > The line "lrwxrwxrwx 1 root root 16 Feb 10 07:49
> /usr/lib/libsnmp.so.0.4.2
> > > ->libsnmp-0.4.2.so" looks strange.
> > >
> > > Is this a symlink pointing to itself? If it is you might have to
> uninstall
> > > ucd-snmp, clean up the dangling symlinks, and reinstall.
> > >
> > >
> > > Regards,
> > > Andrew Hood
> > > A distributed system is one in which the failure of a computer you
> didn't
> > > even know existed can render your own computer unusable. -- Leslie
> > Lamport,
> > > as quoted in CACM, June 1992
> > >  <<ethereal-0.8.15.patch>>
> > >
> > > -----Original Message-----
> > > From: Guy Harris [mailto:guy@netapp.com]
> > > Sent: Monday, 19 February 2001 13:10
> > > To: Mike Cannon
> > > Cc: ethereal-users@ethereal.com
> > > Subject: Re: [Ethereal-users] make failure with redhat 7.0.90
> > > "fisher"
> > >
> > > > Here is the log and thanks again for your time.
> > >
> > > configure:3822: checking for sprint_objid in -lsnmp
> > > configure:3842: gcc -o conftest -Wall -g -O2 -I$(top_srcdir)
> > > -I$(top_srcdir)/wiretap -I$(top_srcdir)/epan -I/usr/local/include
> > > -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/pcap
> > > -I$(top_srcdir) -I$(top_srcdir)/wiretap -I$(top_srcdir)/epan
> > > -I/usr/local/include -I/usr/include/pcap  -L/usr/local/lib
> > conftest.c -lsnmp
> > >
> > > -lz  1>&5
> > > /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsnmp.so:
> > > undefined
> > >     reference to `EVP_DigestInit'
> > > /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libsnmp.so:
> > > undefined
> > >     reference to `EVP_DigestFinal'
> > >
> > > ...
> > >
> > > It looks as if this version of SNMP requires a crypto library of some
> > > sort.  If it's an SSL library, then the next version of Ethereal will
> > > either automatically look for the SSL library or will require you to
> > > configure with "-with-ssl" on platforms where the SNMP library was
built
> > > to require the SSL library.  (I didn't write the SSL checking stuff,
and
> > > I don't remember which of those the person who did write it said it
> > > does.)
> > >
> > > For now, you will probably have to re-run configure with
> > >
> > > --disable-snmp
> > >
> > > and then rebuild.  This will cause Ethereal to dissect SNMP but will
> > > cause it *NOT* to attempt to use the UCD SNMP library to more
> > > symbolically dissect SNMP packets.
> > >
> > > _______________________________________________
> > > Ethereal-users mailing list
> > > Ethereal-users@ethereal.com
> > > http://www.ethereal.com/mailman/listinfo/ethereal-users
> > >
> >
>
>
> _______________________________________________
> Ethereal-users mailing list
> Ethereal-users@ethereal.com
> http://www.ethereal.com/mailman/listinfo/ethereal-users
>
Comment 1 Phil Knirsch 2001-06-26 10:14:13 EDT
Fixed in rawhide. I just tried it myself with the newest ethereal and ucd-snmp
packages installed.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.