Bug 29143 - hangs checking WP bit
hangs checking WP bit
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 16:54 EST by Henri Schlereth
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 18:32:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-02-23 16:54:46 EST
Up until beta2 this machine would install via NFS at least even if the cdrom drove was not probed properly
Now it hangs on bootup when it checks the processor honouring the WP bit. After 15 minutes the screen
blanks and then the keyboard goes dead. 

Requires a power off/on to reboot back to RH70. Test ended until NFS tests are run.


Machine ID/name: #4/shonjir
CPU: 486 1
Memory: 16MB 1
Motherboard: N/A 1
Video: Trident 1MB SVGA 1
Storage: WDC AC13200B 3098MB IDE 1
CD-Rom: Panasonic CR-563 5 *
Network: 3c503 Etherlink II-TP ISA 2

lspci:
N/A
lspci -n:
N/A

Bugzilla entries:

22755 sbpcd.o no longer detects at base address 0x230
installer/kernel

* Works in all releases from RH7 back.
Comment 1 Henri Schlereth 2001-02-23 22:54:15 EST
Additional info: Tried a NFS install and the bootnet.img acts the same way. The diskettes are not defective because I have
used them on two other machines. (both P133's however).

I scared up another 486 with the same results. Machine data as follows:
So this machine also hangs on the WP check.

Machine ID/name: #5/fire

CPU Intel 486 SX/2 - Stepping 0B 1
Memory: 20MB 1
Motherboard: N/A 1
Storage: Quantum Fireball lct10 5 4884MB IDE 1
         COMPAQ CR-589 ATAPI CD-Rom Drive 1
Network: 3c509-B ISA 2
Video:   VGA 1

lspci:
lspci -n:

No PCI bus
Comment 2 Henri Schlereth 2001-02-23 22:55:58 EST
Ignore the machine name, I used another template to generate a new template and forgot to change the machine name.
Comment 3 Arjan van de Ven 2001-02-24 06:33:41 EST
This is a known problem. The cause has been found to be the fix of an
SMP race in the vmalloc kernel code, which broke the WP bit on some
specific CPU's. (486's, Cyrix and Winchip)
A fix will be included in the next kernel we build.
Please reopen this bug if a kernel > 2.4.1-0.1.13 does not solve this bug.
Comment 4 Henri Schlereth 2001-02-24 09:52:29 EST
Can I get a time estimate on this? I have some outstanding beta test bugs that need the use of one of those machines, and
will there be img files that are compatible with the RC1/Wolverine CD's?
Comment 5 Michael K. Johnson 2001-02-27 18:31:05 EST
Current rawhide should have a sufficiently recent kernel
Comment 6 Michael K. Johnson 2001-02-27 18:32:03 EST
Marking NEEDINFO pending results of newer kernel
Comment 7 Henri Schlereth 2001-03-01 21:06:03 EST
Ran a test with the boot.img and bootnet.img as provided by Arjan van de Ven and both machines got past the WP point.
Since this was a simulated test as the Wolverine CD's have the buggy kernel that means to me it is fixed as far as I can
tell.

Note You need to log in before you can comment on or make changes to this bug.