Bug 29167 - installer munges user homedir dotfiles
installer munges user homedir dotfiles
Status: CLOSED DUPLICATE of bug 19982
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 01:07 EST by Seth Vidal
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 14:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original bashrc of this user before the install (192 bytes, text/plain)
2001-03-08 14:08 EST, Seth Vidal
no flags Details
bashrc of the user AFTER the install (192 bytes, text/plain)
2001-03-08 14:08 EST, Seth Vidal
no flags Details

  None (edit)
Description Seth Vidal 2001-02-24 01:07:36 EST
Situation:
Installing wolverine on a system that already has  a /home from an older
install. If you reinstall / (not upgrading the system). When you're
prompted to create users you create a user who's homedir already exists in
/home - at this point everything is fine.

The user who's dir you created will have their .bashrc and .bash_profile
files munged some chars from certain lines are removed.

I've been able to recreate this on two different systems.

Is there some regex magic going on b/c it appears to be some sort of s///
that is grabbing and replacing the wrong text.
Comment 1 Glen Foster 2001-03-02 13:05:54 EST
Our installer team-lead thinks we should really fix this before next release.
Comment 2 Matt Wilson 2001-03-05 12:16:58 EST
please attach the before and after dotfiles.
Comment 3 Seth Vidal 2001-03-08 14:08:05 EST
Created attachment 12122 [details]
original bashrc of this user before the install
Comment 4 Seth Vidal 2001-03-08 14:08:51 EST
Created attachment 12123 [details]
bashrc of the user AFTER the install
Comment 5 Nalin Dahyabhai 2001-03-09 01:50:56 EST

*** This bug has been marked as a duplicate of 19982 ***

Note You need to log in before you can comment on or make changes to this bug.