Bug 291891 - schema file missing from proftpd-ldap package
schema file missing from proftpd-ldap package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: proftpd (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 02:49 EDT by Fran Taylor
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.3.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 10:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
schema file for mod_quotatab_ldap (388 bytes, text/plain)
2007-10-10 15:03 EDT, Fran Taylor
no flags Details

  None (edit)
Description Fran Taylor 2007-09-15 02:49:33 EDT
Description of problem:

The schema file is missing from the proftpd-ldap package.  Other packages that
use LDAP, such as Samba, install a schema file in /etc/openldap/schema

Version-Release number of selected component (if applicable):

proftpd-ldap-1.3.0a-8.fc7
Comment 1 Matthias Saou 2007-09-24 08:05:43 EDT
What file are you referring to? Sure, samba adds a file because it needs extra
attributes for the SID, the extra password fields... but what does ProFTPd
require? Doesn't it directly work with LDAP for user authentication for you?
Comment 2 Matthias Saou 2007-10-09 13:48:25 EDT
Well, closing NOTABUG since I don't think proftpd needs any kind of special
additional attributes like Samba does. If I'm wrong, please detail and reopen
the bug report.
Comment 3 Fran Taylor 2007-10-10 15:03:16 EDT
Created attachment 223271 [details]
schema file for mod_quotatab_ldap
Comment 4 Fran Taylor 2007-10-10 15:04:46 EDT
Additional schema definitions are required for mod_quotatab_ldap.  I have
attached a file containing them.
Comment 5 Matthias Saou 2007-10-22 10:50:29 EDT
I've included the file as %doc, as well as an LDIF file for Fedora Directory
Server created by converting your schema file. I did not want to include the
file directly in the openldap path, since nothing says that the LDAP server
should be on the same machine, so then requiring openldap-servers to have the
parent directories owned would be wrong.

The 1.3.1-2 packages containing this change have been built for F-8 (updates),
devel and F-7 updates testing, so they should show up shortly.

Thanks for your patience ;-)

Note You need to log in before you can comment on or make changes to this bug.