Bug 29194 - [ps/2] XFree86 hangs/segv on VIA 686B chipset with AGP cards
[ps/2] XFree86 hangs/segv on VIA 686B chipset with AGP cards
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ben LaHaise
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 11:20 EST by Jerry Clotfelter
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 15:07:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Clotfelter 2001-02-24 11:20:31 EST
On both fisher and wolverine, XFree86 hangs at "test settings" till the
mouse is moved.
Then segfaults.  This happens with generic serial mouse, generic 3 button
ps/2 mouse
and with logitech 3-button ps/2 mouse.  I continued install and have tried
every combo
of Xconfig with 4 different video cards (all AGP) using the default driver
as
recommended by Xconfigurator and trying reasonable alternatives including 
generic vga.  Have also tried different memory/monitor combos, all with the
same results.  Have also tried altering BIOS settings to no avail.
All of the system combos described below work fine with Redhat 7.0

Reproducible: Always
Steps to Reproduce:
Option A:
 1. boot wolverine or fisher CD	
 2. choose all defaults or pick your own config
 3.  hit test settings

Option B:
 1.  install wolverine and skip XFree86 configuration
 2.  after install, configure XFree in any reasonable combo
 3.  test settings or just run "startx"


Actual Results:  With CD boot, system goes through normal bootup/anaconda
config and the anaconda xserver works fine in all cases.  Once you get to
the X configuration, system hangs till the mouse is moved,
the screen blanks for a second then returns to config screen

On regular install, Operating system works fine all services seem to
be available. When you run startx the screen goes blank then returns
with fatal server error (segv)

Testbed:
  Systems that show the problem
    1Ghz Athlon on Asus A7V133 -KT133A chipset (VIA 686B southbridge)
    700Mhz Athlon on FIC AZ11E -KT133 chipset (VIA 686B southbridge)

  Systems that work fine
    1Ghz Athlon on ABit KT7-RAID - KT133 chipset (VIA 686A southbridge)
    450Mhz P3 on Freetech motherboard (intel chipset)
    350Mhz K6 on EFI motherboard (VIA MVP chipset)

Available Video Cards for testing
  ATI Rage Pro 
  ATI Rage IIC
  Matrox G100
  Nvidia TNT II
  Nvidia 128 (STB Velocity 128)
  Banshee (16Mb Monster Fusion)

All tests so far are with AGP cards.
I Will try to get pci card for testing this weekend and post results
Comment 1 Jerry Clotfelter 2001-02-24 12:07:20 EST
Found an Nvidia 128 PCI video card to test.
PCI card works OK.  Problem seems limited
to the AGP bus.
Comment 2 Jerry Clotfelter 2001-02-24 12:47:52 EST
Ammendment to previous additional comment:

xserver still hangs until mouse is moved even on PCI
but once mouse is moved xserver test works OK.  
This test was run under option A: booting from CD
Comment 3 Jerry Clotfelter 2001-02-24 13:23:42 EST
As a followup test, I down-leveled the Xserver to
XFree86-4.0.1 from the RedHat 7.0 cd and it seems
to work fine.  no AGP problems, no hang till mouse
is moved problems.
Comment 4 Mike A. Harris 2001-02-25 08:49:04 EST
From a configuration that does not work for you of the X package that comes
in Wolverine, please attach to this bug report your XServer configuration
(XF86Config-4) and the XFree error logs found in /var/log.  At first I'd have
been inclined to think it was an agpgart problem, but now I'm not sure.

Looks like it may be a mouse driver problem.  Try picking a different mouse
driver.  Try Logitech Mouseman+ Wheel, and also try the PnP one.  I use a
logitech PS/2 mouse with no problem this way.  Also, try running X with
"noaccel" enabled, and with "nodri" as well.  My guess is it is the mouse
though.  There have been some kernel related ps/2 problems also, so I'll Cc
someone from the kernel group.
Comment 5 Mike A. Harris 2001-02-25 09:09:04 EST
Ok, just got word from the kernel guys, this is a known kernel bug.
Reassigning to kernel package.
Comment 6 Jerry Clotfelter 2001-02-26 16:13:48 EST
Note: I am not sure that this is a PS/2 problem since it exists
with a generic serial mouse as well as a PS/2 mouse.  The
Logitech mouseman was the first driver I tried, then generic
ps/2 then I unplugged the ps/2 mouse and rebooted with
a generic serial mouse attached and got the same results in
all cases.  I tired multiple combinations of mouse drivers with
various vidio cards / drivers to no avail.

I am not familiar with nodri but the problem exists with generic VGA
which, I believe, is not accelerated.   Also, do you still want the 
configuration and log files?  I am currently running the 
4.0.1 package that came with RH 7.0 with no problems except Gnome
doesn't think that sawfish is running so I cannot do any desktop 
configuration. If necessary, I can reinstall the 4.0.2 packages from 
wolverine to get the config and log files.   -   Let me know.
Comment 7 Ben LaHaise 2001-04-18 12:29:42 EDT
Can you confirm if the bug is fixed/not in Seawolf?
Comment 8 Jerry Clotfelter 2001-04-18 12:49:14 EDT
I will give it a try as soon as I can get a copy.
Comment 9 Jerry Clotfelter 2001-05-07 16:31:35 EDT
With RH 7.1 the loader still hangs until the mouse is moved
with an agp video card.  However, with the latest release
when the mouse is moved the xserver seems to load normally.
Have only been able to try this booting from the CD.  Will
confirm with startx once I have a system loaded with 7.1.
Comment 10 Mike A. Harris 2001-08-09 15:06:57 EDT
Have you confirmed this is working now?  Aparently it is fixed now
for quite some time, changing status to MODIFIED.
Comment 11 Jerry Clotfelter 2001-09-05 22:33:00 EDT
Sorry it took so long to be able to do full test.
Once 7.1 was loaded, could not start xserver
with any configuration.  Had trouble freeing up
machine long enough to do proper testing.
This machine is also a key router.  Anyway,
We can close this problem.  With the latest
kernel and libraries the xserver works fine on
an ATI AGP video card.  There is, however,
a problem with the Matrox M100 driver which
is why I could not report good results until
I could shutdown the machine and replace
the video card.
Comment 12 Glen Foster 2001-09-06 09:55:58 EDT
Changing QA contact to dkl

Note You need to log in before you can comment on or make changes to this bug.