Bug 292071 - revisor aborts with errors when created CD isos from loopback mounted DVD image
revisor aborts with errors when created CD isos from loopback mounted DVD image
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 11:03 EDT by Ron Flory
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 20:30:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error/debug output from revisor (972 bytes, application/octet-stream)
2007-09-15 11:03 EDT, Ron Flory
no flags Details
Error/debug log from revisor (972 bytes, text/plain)
2007-09-15 11:07 EDT, Ron Flory
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 246814 None None None Never

  None (edit)
Description Ron Flory 2007-09-15 11:03:51 EDT
Description of problem:

 Attempting to use revisor to create CD isos always fails.


Version-Release number of selected component (if applicable):

 1. revisor-2.0.4.1-2.fc7
 2. System is up to date as of Sat, 09/15/2007.
 

How reproducible:

 Always: 100% (I have been trying to create a CD image set for weeks now).


Steps to Reproduce:
 1. Mount iso image of FC7 DVD via loopback to /mnt/other
 2. Add config frag to revisor f7-i386 config file

[fedora-local]
name=Fedora 7 - Moonshine - i386 - Loop Mounted ISO Image
baseurl=file:///mnt/other/
enabled=0
gpgcheck=1

 3. Start revisor (from root shell, GUI breaks same except no debug output).
 4. select "CD" Installation media Type.
 5. select Loop Mounted ISO image from config frag above, deselect all others.
 6. Click "Apply", then Forward.
 7. At warning dialog, tell revisor to delete any 'old' working files/dirs.
 8. Disable all Kickstart checkboxes in the "Advanced" area., click Forward.
 9. Select "List" tab of Package Selection.  Click "Select All", Forward.
10. Programs churns along until "Creating CD ISO images", then aborts:

    a. During "Build isolinux and installer", saw the error message:
       "TIOCGWINZ ioctl failed, defaulting to 80 columns"
       several times, probably just a nuisance warning.

11. During the "Creating CD ISO images" phase:

   a. Task progress: none, status says "Running Package Order"
   b. Error/debug output to launching shell is attached.

12. GUI application hangs. Click on "Quit" to abort.

  
Actual results:

 None, program aborts.


Expected results:

 7 CD ISO FC7 install images.


Additional info:

 I have been trying to generate a simple CD iso set for weeks now.  This is
necessary because the FC7 installer does not appear to support PCMCIA ethernet
cards any more (I have a box full that work under earlier releases, FC7 does not
recognize even one of them).   This laptop supports only CD media, DVD is not an
option.

 If only Fedora would post the CD set, hundreds, perhaps thousands of installers
would not have to take an hour, and fight the bugs in an attempt to generate
their own.
Comment 1 Ron Flory 2007-09-15 11:03:51 EDT
Created attachment 196431 [details]
Error/debug output from revisor
Comment 2 Ron Flory 2007-09-15 11:07:52 EDT
Created attachment 196441 [details]
Error/debug log from revisor
Comment 3 Makoto Mizukami 2007-10-02 03:40:48 EDT
In may case, this occurs not only making from loopback mounted DVD but also from
normal repository (ex. http://ftp.riken.jp/pub/Linux/fedora/...) .But, if I
selected 'DVD Set', revisor wroks well and complete the work safely.
Comment 4 Jonathan Steffan 2007-10-09 03:39:43 EDT
Hmm.. anyone willing to try this same task with pungi? Just reading the
traceback leads me to think the issue is in the doPackageorder() provided by
pungi (though, I don't know if we've hacked up that function more then just
adding the callback in the version of revisor you are using)...

Also, please try to reproduce the issue with the revisor from updates-testing.
We are going to try to get a new version out soon, and community testing would
be awesome.
Comment 5 Jonathan Steffan 2007-11-10 20:25:30 EST
This should work in 2.0.5, running on f7. We are working out bugs running 2.0.5
on f8: https://bugzilla.redhat.com/show_bug.cgi?id=351941

Note You need to log in before you can comment on or make changes to this bug.