This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 292211 - gzip-compressed data doesn't get decoded anymore
gzip-compressed data doesn't get decoded anymore
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 17:58 EDT by Erik van Pienbroek
Modified: 2013-07-02 19:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 09:52:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Wireshark dump containing the gzip compressed data (1.38 KB, application/octet-stream)
2007-09-15 17:58 EDT, Erik van Pienbroek
no flags Details
Testcase (463 bytes, text/x-csrc)
2007-09-16 16:14 EDT, Erik van Pienbroek
no flags Details

  None (edit)
Description Erik van Pienbroek 2007-09-15 17:58:20 EDT
I already mentioned this bug in #266021, but I was told to file a seperate bug.

A few days ago the curl package switched from OpenSSL to NSS. This change has
caused a program of mine to fail working correctly.

This program of mine retrieves a gzip compressed webpage from some webserver.
Normally curl automatically decodes this gzip stream to normal readable data.
However the change introduced in curl 7.16.4-3 has caused my program to stop
working correctly. The gzip stream isn't automatically decoded anymore. From
7.16.4-3 on my program has stopped functioning correctly. This problem still
occurs with 7.16.4-6. If I reinstall 7.16.4-2 (using rpm --oldpackage) the
problem disappears.

Due to the fact this webserver is only accessible for registered users I'm not
able to provide you a testcase. However, I can give you a wireshark dump which
shows the traffic involved. In the wireshark dump there are no differences
visible in using 7.16.4-2 or a later version of curl, so I'm only attaching the
dump created using curl 7.16.4-6.
Comment 1 Erik van Pienbroek 2007-09-15 17:58:20 EDT
Created attachment 196561 [details]
Wireshark dump containing the gzip compressed data
Comment 2 Erik van Pienbroek 2007-09-16 16:14:04 EDT
I've been able to create a testcase after all. This is now attached to this
bugreport. With curl 7.16.4-2 or earlier some XML output is shown (expected),
while with 7.16.4-3 or later only gzip compressed data is shown.
Comment 3 Erik van Pienbroek 2007-09-16 16:14:36 EDT
Created attachment 196771 [details]
Testcase
Comment 4 Jindrich Novy 2007-09-17 08:36:41 EDT
Adding the NSS guys to Cc.
Comment 5 Tomas Mraz 2007-09-17 09:14:43 EDT
It's completely unrelated to the NSS port. There is a missing Buildrequires:
zlib-devel in spec.
Comment 6 Jindrich Novy 2007-09-17 09:52:38 EDT
Right, it seems like zlib-devel was removed from the exceptionlist sometime
between 7.16.4-2 and 7.16.4-6 because curl has never had the explicit zlib-devel BR.

Added since 7.16.4-7.

Note You need to log in before you can comment on or make changes to this bug.