Bug 292271 - pirut's download dialog a little too chatty
pirut's download dialog a little too chatty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-15 23:57 EDT by Paul W. Frields
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 14:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2007-09-15 23:57:48 EDT
Description of problem:
The pirut dialog during downloads tries to fit the URL of the downloading
package into the progress bar.  In practice the URL rarely fits into the given
space so it just looks goofy.  I'm not arguing against change, but is this
really helping  the desktop user in some way?  I'd think just having the legent
"Downloading <package_name>" is sufficient.

Version-Release number of selected component (if applicable):
1.3.18-1.fc8
Comment 1 Jeremy Katz 2007-09-17 19:56:01 EDT
It's not in the progress bar any more, which makes it a little better.  The
problem with just showing the package name is when downloading, eg, the metadata
for a set of repositories, it's helpful to know where things are downloading from.  
Comment 2 Paul W. Frields 2007-09-17 20:59:48 EDT
Right, but:

1. As of the night before last, the display still couldn't show the URI
correctly because of width issues.  So doesn't that defeat the point a bit?  and...

2. If this is a desktop user tool, do we expect them to do something with that
information?  I suppose they could report it, but how and where?  Surely we
don't expect them to open a terminal and "killall -SIGFOO pirut".

I'm playing a bit of devil's advocate here, but you get the point.  I guess this
would make more sense if there were a progress text area that would become
openable (i.e. an optional expand-O-box arrow) only in the event of a failed
HTTP get.  Even then, though, I'm curious what the goal is.
Comment 3 Jeremy Katz 2007-09-18 14:16:50 EDT
The main reason has been people wanting to have a better idea of what's going
on.  But you've convinced me that it's probably overkill and so nuked from CVS,
will be in 1.3.20

Note You need to log in before you can comment on or make changes to this bug.