Bug 292761 - error from cobbler logrotate
Summary: error from cobbler logrotate
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cobbler   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael DeHaan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-17 07:12 UTC by Joe Orton
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 14:34:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2007-09-17 07:12:01 UTC
Description of problem:
The cobbler logrotate config file needs the "missingok" keyword to suppress an
error from logrotate if no log files are present.

The keywords:

   rotate 4
   weekly

are also redundant since they are present in the system-default logrotate.conf,
so should be omitted in per-service files.  I suggest having:

/var/log/cobbler/cobblerd.log {
   missingok
   notifempty
   postrotate
      if [ -f /var/lock/subsys/cobblerd ]; then
         /etc/init.d/cobblerd restart
      fi
   endscript
}

Comment 1 Michael DeHaan 2007-09-17 14:34:59 UTC
Being explicit doesn't hurt anything, though I've added the missingok and
notifempty for the next release.

Thanks!




Note You need to log in before you can comment on or make changes to this bug.