Bug 29314 - Tin locks computer solid while threading articles
Tin locks computer solid while threading articles
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tin (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 19:45 EST by John Eckerdal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 19:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckerdal 2001-02-24 19:45:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19pre9 i586; Nav)


From time to time tin will lock the computer solid while threading articles
(this is the
message in the tin "status bar"). Ie, it has downloaded the articles and
then started threading them but does not display the article info yet.
Happens with different newsservers, all "remote" - NNTPSERVER env variable
is set
and tin is started tin -r

This happens both in X (running from an x-term) or remotly via SSH (has
occured both
with ssh.com:s SSH version 1.2.27 and OpenSSH 2.3.0pl1). Have not tried a
plain
login-prompt. Has also occured with kernels 2.2.17, 2.2.18, 2.2.19pre9.
These are
not RedHat compiled kernels - but they function in every other case except
this.

Has only seen this with newsgroups with > 1000 articles and it is a
non-regular bug
and I can't reproduce it easily (happens very randomly).

Reproducible: Sometimes
Steps to Reproduce:
1. Start tin with and connect to a remote server (tin -r)
2. Select a group with > 1000 messages
3. See if computer locks while tin is "threading articles"
	

Actual Results:  Computer locks solid (no error messages in logs after
restart and no OOPS info seen).

Expected Results:  Program displaying article info

tin version 1.4.4

After restarting the computer one sometimes manually have to run e2fsck to
repair
filesystem problems that might have occured.

The bug is not as annoying as the outcome. The computer should not lock
solid.
Comment 1 Preston Brown 2001-03-05 16:29:52 EST
there is _no way_ tin could lock the computer up.  Only a kernel crash could
lock the computer up.  A kernel crash under heavy CPU load (like threading
articles) is usually indicative of flakey hardware, bad memory, overclocking, or
the like.

We have no other reports of this nature, and we cannot duplicate the behaviour
here, so we must go on the assumption that your hardware is flakey.  If you can
duplicate this on another computer, please re-open.

Note You need to log in before you can comment on or make changes to this bug.