Bug 29325 - installer hangs reading PLEXTOR CD-R PX-W8432T
installer hangs reading PLEXTOR CD-R PX-W8432T
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 22:52 EST by Havoc Pennington
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 11:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hdparm output of HD (512 bytes, text/plain)
2001-03-16 16:36 EST, Red Hat Bugzilla
no flags Details
hdparm output of CDRW (432 bytes, text/plain)
2001-03-16 16:37 EST, Red Hat Bugzilla
no flags Details
lspci output (13.32 KB, text/plain)
2001-03-16 16:38 EST, Red Hat Bugzilla
no flags Details

  None (edit)
Description Red Hat Bugzilla 2001-02-24 22:52:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; 0.8)
Gecko/20010217


Installer hangs indefinitely (or longer than I had the patience to wait)
with these errors on the console (approximate, hand-copied):

  irq timeout status = 0x80 { Busy }
  end_request: I/O error dev 03:40 sector 1129088
  status timeout status = 0x80 { Busy }
  drive not ready for command
  ATAPI reset complete

Maybe a bad CD? I can try another CD, or even bring in the drive, let me
know what's helpful.

The hang is while the Red Hat logo is displaying, i.e. X comes up before
this stuff starts.

Guessing kernel bug, may be the installer, dunno.

Drive works OK with 7.0, with both ide-scsi and regular IDE drivers.
Running 2.2 kernel with 7.0.
Comment 1 Red Hat Bugzilla 2001-02-26 05:18:16 EST
Are you sure this is not a medium error ? (can you make a md5 of _this_ cd
in our 2.2 kernel )
Comment 2 Red Hat Bugzilla 2001-02-26 11:14:38 EST
I can, but I'm using the ide-scsi driver rather than the IDE driver the
installer uses:

# md5sum /dev/scd0 
a95507f8bb00800a8d05799dd7e6e57e  /dev/scd0

I'll bring the CD to the office today and see if it works on other machines.
It probably is a broken CD if those error messages make you think that. It's a
CD-R after all.
Comment 3 Red Hat Bugzilla 2001-02-26 18:57:46 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 Red Hat Bugzilla 2001-02-27 15:22:58 EST
I successfully installed from the same CD on my work machine, 
"Lite-On LTN483S 48x Max" drive. Let me know what other debugging would be helpful.
Comment 5 Red Hat Bugzilla 2001-02-27 19:03:57 EST
One last question: can you read other CDs fine with that drive
and the wolverine kernel?
Comment 6 Red Hat Bugzilla 2001-02-27 19:15:53 EST
I'll try installing with different disks and see if it works.
Comment 7 Red Hat Bugzilla 2001-03-06 15:53:28 EST
Could not reproduce the problem using the same CD-ROM drive and CDs in question.
The CD's and CD-ROM drive appear to work fine in other systems. Testing was done
using IDE HD's with various settings.

This may mean his motherboard and/or other IDE devices are involved in this
failure.

Havoc is going to try the CD's using a different CD-ROM drive in his system and
see if that also fails, and try more recent CD's with updated kernels in the
original setup to see if we still have this failure to fix.
Comment 8 Red Hat Bugzilla 2001-03-07 03:37:12 EST
It would be interesting to see if "ide=nodma" on the lilo commandline
works with a installer based on kernel 2.4.2-0.1.20 or later
Comment 9 Red Hat Bugzilla 2001-03-07 12:58:24 EST
and the output of /proc/ide/hdX/model would be very welcome
(of the failing drive)
Comment 10 Red Hat Bugzilla 2001-03-07 13:40:27 EST
I think I took the summary line from /proc/ide/hdX/model (PLEXTOR CD-R PX-W8432T
)
Comment 11 Red Hat Bugzilla 2001-03-07 23:34:07 EST
OK, so more details. There are three CDs and two CD drives that I've tested.
The CDs are two Wolverine betas, and one snapshot with kernel 2.4.2-0.1.20.
The drives are the Plextor and an older Memorex.

The Plextor fails with all three CDs. Booting with "linux ide=nodma" makes no
difference; I get the same error messages about DMA, and "cat
/proc/ide/hdb/settings" shows the same value for using_dma. So not sure if I'm
getting this boot parameter right.

The Memorex drive works with all three CDs, there are no problems.

Keith's testing reveals no problems with the Plextor and a different mainboard.

I noticed more error messages on the console; the original messages I reported
are repeated over and over, but there are some one-time messages that had
scrolled off the top or maybe only happen with the newer kernel. These are:
 timeout waiting for DMA
 ide_dma_proc: chipset supported ide_dma_timeout func only: 14
 irq timeout: status = 0xd8 { Busy }
 DMA disabled

Then the error messages I reported originally repeat over and over. The messages
are the same regardless of "ide=nodma".

From /proc/pci, details on the IDE controller: 
Bus  0, device   7, function  1:
    IDE interface: VIA Technologies VT 82C586 Apollo IDE (rev 6).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=32. 
      I/O at 0xb000 [0xb001].

This is a Duron motherboard, AOpen AK73 Pro with a VIA KT133 chipset.
Comment 12 Red Hat Bugzilla 2001-03-08 16:22:15 EST
This is not good.

Since other CDROMs work fine in your system and the Plextor doesn't, and the
Plextor works here, that means that part of the problem has to do with a
relationship with your other hardware and/or bios. The fact that even current CD
failed means that if this is a bug, it exists even in our current builds.

You mentioned to me (in person) that you weren't sure you had the Plextor drive
when you did your original 7.0 installation. Could you try a 7.0 installation
using the Plextor and see if that works? That will tell us if this really is a
new problem or not.
Comment 13 Red Hat Bugzilla 2001-03-09 01:48:15 EST
7.0 install does come up, and as I mentioned before I can md5sum /dev/hdb 
from the running 7.0 system. I've also done a 'cat /dev/hdb' to get CD images
for duplication on this system before.

However the 7.0 install had some possibly interesting error messages on the console:
 hdb: cdrom_decode_status: status = 0x51 { DriveReady SeekComplete Error }
 hdb: cdrom_decode_status: error = 0x34
those two lines repeated 3 times, then a while later:
 hdb: disabled DSC seek overlap

ring any bells?
Comment 14 Red Hat Bugzilla 2001-03-09 17:09:43 EST
Havoc, what's the possibility of having your system brought here (in-house) to
see this behavior?  It'd be a lot easier for us, if not more time-efficient for
everyone else.  Can you bring in the whole kit-and-kaboodle instead of 1 or 2
peripherals at a time?
Comment 15 Red Hat Bugzilla 2001-03-09 17:43:10 EST
Sure I can bring it in, just give me a day when someone can definitely look at
it, to minimize my computer-less time. (I might have withdrawal symptoms... ;-)
Comment 16 Red Hat Bugzilla 2001-03-16 16:35:00 EST
Here is some additional information.

1. Turning on/off BIOS "OS supports Plug-n-play" does not affect problem.

2. Replacing the IDE cable made no difference.

3. "ide=nodma" made no difference

4. Using different HD's with the CDRW makes no difference

5. Swapping Master/Slave settings makes no difference.

But...

6. Removing the HD from the same (primary) IDE chain (so the CDRW was
   the only device on it) allowed the CDRW to work fine.

7. Moving the CDRW and HD to the secondary IDE controller works
   (i.e. they work together)

8. As as was already pointed out, replacing the CDRW with a different
   CDROM works.

   AND

9. Using this CDRW with a different motherboard & HD works, although that did
not go through the extensive testing this system did.


This looked like an IDE protocol problem (i.e. the 2 devices using different
protocols on the same cable), except that moving both devices to the secondary
controller seems to work.

Since any HD with this drive fails, and only on this system, it must be some
sort of relationship conflict. The fact that 7.0 worked and 7.1 does imply that
some IDE change did take place.

Attached are hdparm and lspci output from the Linux OS already installed on the
system

Comment 17 Red Hat Bugzilla 2001-03-16 16:36:36 EST
Created attachment 12822 [details]
hdparm output of HD
Comment 18 Red Hat Bugzilla 2001-03-16 16:37:14 EST
Created attachment 12823 [details]
hdparm output of CDRW
Comment 19 Red Hat Bugzilla 2001-03-16 16:38:13 EST
Created attachment 12824 [details]
lspci output
Comment 20 Red Hat Bugzilla 2001-03-16 16:42:54 EST
Yes an IDE change took place: We enabled DMA.
Does a recent kernel (0.1.28 or so) work ?
We have this drive in the blacklist now and getting the blacklist confirmed
working would be nice.
Comment 21 Red Hat Bugzilla 2001-03-16 16:59:47 EST
I was using qa0306.0 (2.4.2-0.1.2.0).

If someone can get newer CDs to me or Havoc we could them.
The ones we have were cut on 3/6

Comment 22 Red Hat Bugzilla 2001-03-23 11:36:04 EST
Keith - any progress on this. Its been a few weeks if you need a cd I'm sure we
can make some.
Comment 23 Red Hat Bugzilla 2001-03-26 11:18:17 EST
No; no one has given Havoc any new CDs, and I do not have the knowledge or
server room access to cut them myself (wish I did).

Comment 24 Red Hat Bugzilla 2001-03-29 17:12:10 EST
Drive blacklisted in the kernel. Other workaround is "ide=nodma" on the kernel
command line

Note You need to log in before you can comment on or make changes to this bug.