Bug 293281 - Live CD will not boot off USB pen
Live CD will not boot off USB pen
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-17 10:12 EDT by William Murray
Modified: 2007-12-04 11:26 EST (History)
1 user (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-04 11:26:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description William Murray 2007-09-17 10:12:07 EDT
Description of problem:
Live cd iso will not boot off USB pen

Version-Release number of selected component (if applicable):
F8test2 (also test 1)

How reproducible:
3 machines exhibit same symptoms

Steps to Reproduce:
1. /usr/bin/livecd-iso-to-disk /path/to/live.iso /dev/sdb1 
2. Put pen in usb port
3. reboot computer
Actual results:
Boot hangs at un-compressing the initrd.img

Expected results:
Live USB install

Additional info:
I have tried some kernel boot parameters:
These had no effect.
Comment 1 William Murray 2007-10-05 08:52:43 EDT
This is still true in F8T3. No progress..
Comment 2 Will Woods 2007-12-03 17:42:30 EST
Works fine here. What kind of machine were you trying it in? How much RAM does
it have? How did you make the LiveUSB device?
Comment 3 William Murray 2007-12-04 03:00:00 EST
I have been using a Dell D610 lattitude and laptop and an optiplex 745 with the
same result. Both 1Gb ram.

   The USB device might be issue. I have it partitioned into 3: FAT for other
O/S use, EXT3 with the Live CD and EXT3 with a gParted distro and MBR. Grub
on this appears to correct5ly pass to grub on the 2nd partition, nice blue
splash screen but no loading initrd.img.

I made it using /usr/bin/livecd-iso-to-disk as stated.
  Is there anything I could try? I don't really want to scrub the
partitioning...but I guess I could.
Comment 4 William Murray 2007-12-04 04:31:41 EST
   This was with F8T3. I Just re-did it using F8. And it works perfectly.
One observation...my boot partition has moved. Previously it was left on
the 3rd partition, now it is the second. Maybe connected? Anyway, it works!

Note You need to log in before you can comment on or make changes to this bug.