Bug 293891 - NullPointerException when updating native eclipse-3.3
NullPointerException when updating native eclipse-3.3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-17 16:08 EDT by Jochen Schmitt
Modified: 2008-02-04 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 16:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
running eclipse as root, no NPEs (2.29 KB, text/plain)
2008-02-04 15:06 EST, Lillian Angel
no flags Details

  None (edit)
Description Jochen Schmitt 2007-09-17 16:08:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):

Uupdate and installing of all features of Eclipse 3.3 fails with a
NullPointerException


Steps to Reproduce:
1. Start Eclipse as root
2. Start Software Updates / Find and Install
3. Select Search for new features to install
4. Select all provided features to install
  
Actual results:

Crash with a NullPointerException
Expected results:

Additional info:
Install all selected features.

This issue occured only on IcedTea. Thw issue doesn't occurs when using
Suns JDK 1.6.0 Update 2
Comment 1 Thomas Fitzsimmons 2007-10-15 17:19:09 EDT
Andrew, can you see if you can reproduce this?
Comment 2 Andrew Overholt 2007-10-15 17:23:03 EDT
Before I try, I'd like to note that one shouldn't be running Eclipse as root.
Comment 3 Lillian Angel 2008-02-04 14:39:56 EST
I am not able to reproduce this- I did not run eclipse as root, though.

Andrew- any luck reproducing this problem?

Jochen Schmitt - Do you have the NullPointerException stack trace?
Comment 4 Lillian Angel 2008-02-04 15:06:59 EST
Created attachment 293935 [details]
running eclipse as root, no NPEs
Comment 5 Lillian Angel 2008-02-04 15:07:32 EST
I was not successful in reproducing this problem when running eclipse as root.
See the attached log.

Note You need to log in before you can comment on or make changes to this bug.