Bug 29393 - building kernel make xconfig doesn't work
building kernel make xconfig doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 11:05 EST by Tim Clymo
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 11:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-02-25 11:05:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


There seems to be a bug in the kernel-source distribution. Specifically, in
/usr/src/linux-2.4/net/ipv4/netfilter/ip_vs/Config.in

When trying to configure a new kernel, make xconfig returns an error
referring to line 9 of this file. Worked around by using make menuconfig
instead

Reproducible: Always
Steps to Reproduce:
1. cd /usr/src/linux-2.4
2. make xconfig
	

Actual Results:  error

Expected Results:  should have displayed kernel configuration xclient

[root@tcpc linux-2.4]# make xconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory `/usr/src/linux-2.4.1/scripts'
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkparse.o
tkparse.cgcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o
tkcond.o tkcond.c
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkgen.o
tkgen.c
gcc -o tkparse tkparse.o tkcond.o tkgen.o
cat header.tk >> ./kconfig.tk
./tkparse < ../arch/i386/config.in >> kconfig.tk
net/ipv4/netfilter/ip_vs/Config.in: 9: incorrect argument
make[1]: *** [kconfig.tk] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.1/scripts'
make: *** [xconfig] Error 2
Comment 1 Arjan van de Ven 2001-02-26 04:57:06 EST
The fix for this problem will be in the next kernel build.
In the mean time, you can look at bug 29449  for a workaround.

Note You need to log in before you can comment on or make changes to this bug.