This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29406 - init logs only to level LOG_INFO
init logs only to level LOG_INFO
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 13:25 EST by Leonard den Ottolander
Modified: 2014-03-16 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 22:45:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch file for init.h and init.c to include log levels. Note that I am not sure of all the appropriate log levels, so these should be checked. (26.14 KB, patch)
2001-03-11 11:49 EST, Leonard den Ottolander
no flags Details | Diff

  None (edit)
Description Leonard den Ottolander 2001-02-25 13:25:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)


Concerned package: SysVinit-2.78-5.i386.rpm (and -.src.rpm)

The init binary logs every message with level LOG_INFO. The variable "loglevel" in the function "log" in init.c does not describe the loglevel, but 
whether the message should be logged to file and/or console.
It is probably appropriate to log errors with loglevel LOG_ERR, and the message "Entering runlevel: %c" with level LOG_NOTICE. The latter 
since most daemon debug and info messages can probably be safely logged to a different file than /var/log/messages, but one would want the 
"Entering runlevel" message to end up in /var/log/messages.

I am willing to write a patch for init.c to make the log function use an actual loglevel, and to add the appropriate loglevel to all calls to the 
function "log".


Reproducible: Always
Steps to Reproduce:
1. Run init

	

Actual Results:  Messages will all be logged with loglevel LOG_INFO, including error messages.

Expected Results:  Messages logged with appropriate loglevels.

I am not sure about the severity level that should be assigned to this behaviour. Although not a bug in the strict sense I do believe this 
behaviour 
is not correct. I post this as a low priority bug, although one could call it a normal priority bug, or just an enhancement.
Comment 1 Leonard den Ottolander 2001-03-11 11:49:14 EST
Created attachment 12362 [details]
Patch file for init.h and init.c to include log levels. Note that I am not sure of all the appropriate log levels, so these should be checked.
Comment 2 Leonard den Ottolander 2001-07-20 13:50:06 EDT
20-7-2001: This bugreport still applies to SysVinit-2.78-18.src.rpm, Sun Jun 24 
22:05:00 2001 (rawhide, RH 7.1+)
Comment 3 Bill Nottingham 2002-07-18 22:11:08 EDT
This is something that's probably best integrated upstream first.
Comment 4 Leonard den Ottolander 2002-07-19 07:27:49 EDT
So, should I report it as a request for enhancement under rawhide? The patch works
fine for me. Still leaves the question about appropriate log levels.
Comment 5 Bill Nottingham 2002-07-19 12:20:31 EDT
By upstream I mean the upstream SysVinit maintianer, Miquel van Smoorenburg
<miquels@cistron.nl>.

Note You need to log in before you can comment on or make changes to this bug.