Bug 294061 - udev creates zaptel devices with the wrong file permissions
udev creates zaptel devices with the wrong file permissions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-17 18:56 EDT by Dave Miller
Modified: 2009-01-20 15:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:35:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Miller 2007-09-17 18:56:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install udev
2. Install zaptel
3. Install asterisk and configure it to run as the asterisk user
  
Actual results:
Observe as asterisk fails to access the zaptel devices because they're not
accessible to the asterisk user

Expected results:
udev should not include configuration for the zaptel devices, as configuration
for these devices in udev is already provided by the zaptel driver, and the
verson provided by the zaptel driver correctly sets the permissions to the
asterisk user.

Additional info:

The file /etc/udev/rules.d/50-udev.rules contains the following rules:

# Section for zaptel device
KERNEL="zapctl",     NAME="zap/ctl"
KERNEL="zaptimer",   NAME="zap/timer"
KERNEL="zapchannel", NAME="zap/channel"
KERNEL="zappseudo",  NAME="zap/pseudo"
KERNEL="zap[0-9]*",  NAME="zap/%n"

The zaptel driver installs /etc/udev/rules.d/zaptel.rules with the following:

# zaptel devices with ownership/permissions for running as non-root
KERNEL=="zapctl", NAME="zap/ctl", OWNER="asterisk", GROUP="asterisk", MODE="0660"
KERNEL=="zaptranscode", NAME="zap/transcode", OWNER="asterisk",
GROUP="asterisk", MODE="0660"
KERNEL=="zaptimer", NAME="zap/timer", OWNER="asterisk", GROUP="asterisk",
MODE="0660"
KERNEL=="zapchannel", NAME="zap/channel", OWNER="asterisk", GROUP="asterisk",
MODE="0660"
KERNEL=="zappseudo", NAME="zap/pseudo", OWNER="asterisk", GROUP="asterisk",
MODE="0660"
KERNEL=="zap[0-9]*", NAME="zap/%n", OWNER="asterisk", GROUP="asterisk", MODE="0660"

Since the zaptel driver provides its own rules file, this config should not be
included in the core udev ruleset at all.

Every time I get an update to udev since upgrading our asterisk server to rhel5,
I have to go comment those rules out of 50-udev.rules in order to get asterisk
to work.
Comment 1 Dave Miller 2007-09-17 19:00:31 EDT
This seems to have originated from bug 140496, as best I can tell.  Comment 6 on
that bug seems to imply that the bug was closed because it was no longer needed
since the driver package supplied its own udev rules, however, someone obviously
committed the change anyway.
Comment 2 Harald Hoyer 2007-09-18 05:15:21 EDT
Thx, for getting my attention to this. I am glad to remove these rules from udev.
Comment 3 Dave Miller 2007-11-12 23:07:57 EST
We just pulled the RHEL 5.1 update, which included a new udev, and obviously
this wasn't included in it yet.  It subsequently busted our phone system until
we manually edited the 50-udev.rules file again.
Comment 5 RHEL Product and Program Management 2008-06-02 16:31:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Dave Miller 2008-07-15 17:29:39 EDT
We just pulled the RHEL 5.2 update, which included a new udev, and obviously
this wasn't included in it yet.  It subsequently busted our phone system until
we manually edited the 50-udev.rules file again.
Comment 9 Harald Hoyer 2008-09-12 06:04:37 EDT
please test
http://people.redhat.com/harald/downloads/udev/udev-095-14.19.el5/
Comment 10 Dave Miller 2008-09-12 11:21:54 EDT
(In reply to comment #9)
> please test

Confirmed.  This one indeed does not contain rules for zaptel, thus allowing the driver install to provide its own without stuff breaking. :)

Thanks!
Comment 13 errata-xmlrpc 2009-01-20 15:35:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0076.html

Note You need to log in before you can comment on or make changes to this bug.