Bug 294391 - /var/log/acpid is no longer used
/var/log/acpid is no longer used
Status: CLOSED DUPLICATE of bug 389581
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 04:35 EDT by Jan Kratochvil
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 02:38:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2007-09-18 04:35:05 EDT
Description of problem:
All the messages are now stored in /var/log/messages .
/var/log/acpid is left intact.

Version-Release number of selected component (if applicable):
acpid-1.0.6-1.fc8.x86_64
rsyslog-1.19.2-1.fc8.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Run Rawhide.

Actual results:
$ ls -l /var/log/acpid
-rw-r----- 1 root root 21565067 2007-09-11 01:03 /var/log/acpid
$ date
Tue Sep 18 10:33:30 CEST 2007
/var/log/messages:
Sep 18 10:33:57 host0 acpid: received event "processor CPU0 00000080 00000000"
Sep 18 10:33:57 host0 acpid: notifying client 2563[68:68]
Sep 18 10:33:57 host0 acpid: notifying client 3422[0:0]
Sep 18 10:33:57 host0 acpid: completed event "processor CPU0 00000080 00000000"
Sep 18 10:33:57 host0 acpid: received event "processor CPU1 00000080 00000000"
Sep 18 10:33:57 host0 acpid: notifying client 2563[68:68]
Sep 18 10:33:57 host0 acpid: notifying client 3422[0:0]
Sep 18 10:33:57 host0 acpid: completed event "processor CPU1 00000080 00000000"

(BTW there is a continuous stream of such messages - Lenovo T60, AC power.)

Expected results:
/var/log/acpid is being used for these messages.

Additional info:
If /var/log/acpid should be no longer a separate log you should at least remove:
-rw-r--r--    1 root    root              144 Aug 10 09:09 /etc/logrotate.d/acpid
Comment 1 Zdenek Prikryl 2007-09-18 04:48:40 EDT
According to the changelog, /var/log/acpid is no longer used.

* Wed May 23 2007  Tim Hockin <thockin@hockin.org>
  - Use syslog() for logging (acpid.c, event.c, acpid.h) (Stefan Seyfried    
<seife@suse.de>)

I'll remove /etc/logrotate.d/acpid in this week.

Zdenek
Comment 2 Alan Cox 2007-10-10 10:24:53 EDT
Bizarre question based on some other weird Lenovo goings on - if you turn off
bluetooth do they stop ?
Comment 3 Jan Kratochvil 2007-10-10 20:41:32 EDT
Alan,
The original bug was on:
  kernel-2.6.23-0.171.rc5.git1.fc8.x86_64
It was probably later unreproducible already on:
  kernel-2.6.23-0.214.rc8.git2.fc8.x86_64
And it is now unreproducible on:
  kernel-2.6.23-0.217.rc9.git1.fc8.x86_64

Yes, I have bluetooth internal device + service turned on.
My invocation action was to run some cpu-chewing for(;;); in qemu-kvm.

I hope I do not have to reboot...
Comment 4 Zdenek Prikryl 2007-11-22 02:38:37 EST

*** This bug has been marked as a duplicate of 389581 ***

Note You need to log in before you can comment on or make changes to this bug.