This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 29447 - vfat fs has trouble with ~650 Meg files
vfat fs has trouble with ~650 Meg files
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 16:17 EST by Marty Shannon
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 23:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marty Shannon 2001-02-25 16:17:34 EST
Using scp to copy wolverine ISO images to a vfat filesystem with magicdev
running causes the kernel to chew up CPU (up to about 93% as write cache
approaches full), rendering the system painfully slow.  Same test with ext2
fs shows (the expected) negligible impact.  For folks using multi-boot (for
evil-empire OSs), this is pretty much a show stopper.  (Sorry, Alan.)
Comment 1 Arjan van de Ven 2001-02-26 05:19:50 EST
does this also show without magicdev ?
(not to blame magicdev but to find if there is an interaction)
Comment 2 Marty Shannon 2001-02-26 09:17:50 EST
I ran 4 tests: vfat + magicdev (slow); vfat - magicdev (ok); ext2 + magicdev
(ok); ext2 -magicdev (ok).  So, yes, there is an interaction with vfat &
magicdev.  Just FYI, here's the /etc/mtab in question (since magicdev reads it
once per loop; why not just stat() it, and open if st_mtime changes?):

[mshannon@beast mshannon]$ cat /etc/mtab
/dev/hda5 / ext2 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext2 rw 0 0
/dev/hda7 /export/home ext2 rw 0 0
/dev/hda2 /mnt/nt4c vfat rw,uid=500,gid=500 0 0
/dev/hda3 /mnt/w98c vfat rw,uid=500,gid=500 0 0
/dev/hdc1 /b0 vfat rw,uid=500,gid=500 0 0
/dev/hdd1 /b1 vfat rw,uid=500,gid=500 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
automount(pid753) /misc autofs rw,fd=5,pgrp=753,minproto=2,maxproto=3 0 0

The vfat target was /b0; the ext2 target was /export/home.  If I can supply any
other info, please let me know!
Comment 3 Glen Foster 2001-02-26 18:54:57 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Michael K. Johnson 2001-02-28 23:42:13 EST
What kind of hardware is this?

Could you give us a summary report (processor, chipset,
disk controller) and the output of "lspci -v" please?  Thanks!
Comment 5 Michael K. Johnson 2001-07-03 17:09:21 EDT
If you are still seeing this with Red Hat Linux 7.1, please try the
errata kernel 2.4.3-12.  If you are still seeing it with the errata
kernel please re-open this bug report.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.