Bug 294601 - Yum: IndexError: list index out of range
Yum: IndexError: list index out of range
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 08:17 EDT by Christian Mandery
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.2.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 11:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Mandery 2007-09-18 08:17:34 EDT
Description of problem:
After installing lots of packages, Yum (sometimes) produces an error:

...
  Installing: kdeutils                     ##################### [207/213]
  Installing: kdeartwork                   ##################### [208/213]
  Installing: kdevelop                     ##################### [209/213]
  Installing: munin                        ##################### [210/213]
  Installing: kdebase-extras               ##################### [211/213]
  Installing: kdepim                       ##################### [212/213]
  Installing: munin-node                   ##################### [213/213]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 382, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 579, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 249, in callback
    self._instCloseFile(  bytes, total, h )
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 311, in
_instCloseFile
    self.ts_done(txmbr.po, txmbr.output_state)
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 164, in ts_done
    (t,e,n,v,r,a) = self._te_tuples[0] # what we should be on
IndexError: list index out of range

This is a low priority bug because as far as I can see, all packages are
installed correctly, so it is merely a cosmetically thing.

Version-Release number of selected component (if applicable):
Yum latest Fedora 7 stable version
Comment 1 Seth Vidal 2007-09-18 11:31:44 EDT
This is on yum 3.2.4? Please upgrade to yum 3.2.5 which just moved to stable
updates, please.
 
Comment 2 Christian Mandery 2007-09-18 12:29:34 EDT
Okay, just did the upgrade to 3.2.5 (it must still be very new, since I run yum
update this morning and it did not want to upgrade).
Comment 3 Seth Vidal 2007-09-18 12:46:17 EDT
3.2.5 has been in updates-testing for about a week - it just came out to stable
yesterday. so, yes, it is very new.

Note You need to log in before you can comment on or make changes to this bug.