Bug 294661 - tar -f "hostname:tar_device" usage is broken
tar -f "hostname:tar_device" usage is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar (Show other bugs)
5.0
i686 Linux
low Severity high
: ---
: ---
Assigned To: Ondrej Vasik
:
: 475981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 09:04 EDT by paulm
Modified: 2010-10-22 14:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paulm 2007-09-18 09:04:45 EDT
Description of problem: When using the "hostname:tar_device" convention the 
command immediately fails. 


Version-Release number of selected component (if applicable):
The "hostname:" option works fine in tar-1.14-10.RHEL4, however it does not 
work in tar-1.14-12.5.1.RHEL4 or later (fails on RHEL5 versions too)

How reproducible:
Every Time. 

Steps to Reproduce:
1. Setup two RHEL4 (or RHEL5) servers on network, linuxA and linuxB
2. Create some test files in /tmp/testfiles/
3. On linuxA, run:  tar cvf linuxB:/tmp/test.tar /tmp/testfiles
 
  
Actual results:
You see this error:

tar: linuxB\:/tmp/test.tar: Cannot open: Input/output error
tar: Error is not recoverable: exiting now


Expected results:
A tar file would be created on linuxB /tmp/test.tar which contains 
the /tmp/testfiles from linuxA 

Additional info:
Comment 1 Ondrej Vasik 2008-12-17 10:14:30 EST
*** Bug 475981 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2009-03-26 13:05:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 Issue Tracker 2010-02-17 02:03:58 EST
Event posted on 02-17-2010 04:03pm JST by tumeya

HP verified the 5.5 beta. 


This event sent from IssueTracker by tumeya 
 issue 258179
Comment 14 errata-xmlrpc 2010-03-30 04:19:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0224.html

Note You need to log in before you can comment on or make changes to this bug.