Bug 29472 - anaconda misbehaves on a system with PDC20265
anaconda misbehaves on a system with PDC20265
Status: CLOSED DUPLICATE of bug 29427
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 18:30 EST by Michal Jaegermann
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 13:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full install log from an attempt to install Wolverine (2.00 KB, text/plain)
2001-02-25 18:31 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2001-02-25 18:30:20 EST
Anaconda from Wolverine seems to be very unhappy with a machine
with PDC20265 controller.  An attempt to install only a "Base"
stuff (some 170 MB, all sets checked out in a "custom install")
first blows up spectacularly with an instant reboot; too fast
to really notice what is going wrong.

Using 'linux rescue' in order to mount a root filesyste "to be"
I see the following picture:

total 23
drwxr-xr-x   2 root     root         2048 Feb 25 13:37 bin
----------   0 root     root            0 Feb 25 13:37 boot
drwxr-xr-x   2 root     root         1024 Feb 25 13:37 dev
drwxr-xr-x  25 root     root         2048 Feb 25 13:37 etc
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 home
----------   0 root     root            0 Feb 25 13:37 lib
drwxr-xr-x   2 root     root        12288 Feb 25 13:28 lost+found
----------   0 root     root            0 Feb 25 13:37 mnt
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 opt
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 proc
----------   0 root     root            0 Feb 25 13:37 root
----------   0 root     root            0 Feb 25 13:37 sbin
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 tmp
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 usr
drwxr-xr-x   2 root     root         1024 Feb 25 13:28 var

It is a small wonder that things are not happy.

On another attempt to install in the same way, after the partition
in question was reformatted, a system disintegrates and once again
reboots, without leaving any chance to check things, while installing
"passwd" rpm.  An install.log from that try is attached.

After adding to this remaining packages from "Base" set, and
constructing few configuration files, like /etc/fstab and network
configuration, the whole system boots, seems to be happy and even
gets its network connection working.  But attempts to perform
even a minimal install in a "normal" way so far miserably failed.

  Michal
Comment 1 Michal Jaegermann 2001-02-25 18:31:36 EST
Created attachment 11060 [details]
Full install log from an attempt to install Wolverine
Comment 2 Michal Jaegermann 2001-02-25 18:53:22 EST
Forgot to add in my report.  It does not seem to matter at all if I am
using graphics or text interface while trying to install.
Comment 3 Michael Fulbright 2001-02-26 11:40:50 EST
When does the 'instant reboot' occur?
Comment 4 Michal Jaegermann 2001-02-26 13:03:32 EST
> When does the 'instant reboot' occur?
Various places.  While laying out file systems if you will attempt
bad blocks checking, for example.  But in general when disks are quite
active.  Attached "install" log example gives a pretty good picture.
"Installing passwd" is the last entry and this is the place when the
whole setup rebooted.  A "passwd" package was not installed, or at
least not recorded in rpm database as there were no complaints when
I tried to do that later "by hand".

#29508 has a decoded oops which seems to be typical and see also #29427
for more examples.
Comment 5 Glen Foster 2001-02-26 18:09:51 EST

*** This bug has been marked as a duplicate of 29427 ***

Note You need to log in before you can comment on or make changes to this bug.