Bug 29473 - up2date reports invalid Architecture & OS release combo
up2date reports invalid Architecture & OS release combo
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
: 30553 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 18:31 EST by Steve Howard
Modified: 2015-01-07 18:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 08:46:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Howard 2001-02-25 18:31:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


After running up2date -r for anonymous registration and selecting
Next it the "Welcome to Red Hat Update Agent" during package fetch
this message pops up:

There was a fatal communication with the server. The message was:
Invalid Architecture and OS release combination



Reproducible: Always
Steps to Reproduce:
1. open up console
2. type up2date 
3.
	

Actual Results:  Same results

Expected Results:  Normal up2date activity - i.e., list of updates on
servers
Comment 1 Glen Foster 2001-02-26 18:51:37 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Jay Turner 2001-02-27 08:40:50 EST
What version of Red Hat Linux are you running?  If it is one of the betas, then
that would explain your problems.  We do not support the betas with up2date, as
we do not release official errata for the betas.
Comment 3 Preston Brown 2001-02-27 18:30:47 EST
wolverine and up2date are working with anonymous registration as of today.  I
just checked.
Comment 4 Richard Hyde 2001-02-28 00:10:35 EST
I just used up2date to update 150 some odd packages, up2date included.  After
updating up2date it no longer works and reports the same error as the original
submitter.  When starting up2date on the command line it warns: can't access
/etc/sysconfig/rhn/rhn.  Sure enough, that file does not exist.
Comment 5 Richard Hyde 2001-02-28 18:35:22 EST
Change line 122 of /usr/share/rhn/up2date/config.py from
 self.fileName = "/etc/sysconfig/rhn/rhn"

to

 self.fileName = "/etc/sysconfig/rhn/up2date"

and now up2date works just fine (Again)
Comment 6 Jay Turner 2001-03-01 11:51:07 EST
This is resolved with the 3/1/01 CVS code.  We now have separate config files again.
Comment 7 keith adamson 2001-03-13 09:19:02 EST
Still a problem ... I just up2date this morning to;

Name        : up2date                      Relocations: (not relocateable)
Version     : 2.4.1                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Wed 07 Mar 2001 03:46:10
PM EST
Install date: Tue 13 Mar 2001 08:48:21 AM EST      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM: up2date-2.4.1-1.src.rpm
Size        : 464023                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Automatically update RPMs for a Red Hat Linux System

When I run;

up2date-nox -l

I get;

Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:

ERROR: Invalid Architecture and OS release combination
INFO : N/A

    An unexpected error has occured while processing your request.
    Please try again later or submit a bug report to rhns_help@redhat.com.
    If you choose to submit the bug report, please be sure to include
    details of what were you trying to do when this error occured and
    details on how to reproduce this problem.
    



Comment 8 Jay Turner 2001-03-14 14:13:52 EST
OK, the "fixed in CVS" comment was in reference to the message about not being
able to find the config file.  For the "invalid OS/release" stuff, what version
of the OS is installed?  What server are you pointing up2date at?
Comment 9 Richard Hyde 2001-03-14 14:23:57 EST
"invalid OS/release" problem  has resurfaced (after being corrected with the
above pseudo-patch) with wolverine + latest RawHide updates (from up2date).  No
additional (server pointing) configuration.
Comment 10 Jay Turner 2001-03-14 14:33:19 EST
These two issues are unrelated for the most part.  If up2date is pointing at
www.rhns.redhat.com (which can be confirmed by checking out the serverURL
attribute in 'up2date --config') then that is the problem.  The live site has no
knowledge of the betas and that is why you are seeing this problem.  If you are
still pointing at a different server, then please run 'less /etc/redhat-release'
and post the results.
Comment 11 Preston Brown 2001-03-14 17:21:56 EST
up2date itself is fine.  Anything left is a server side issue.
Comment 12 Preston Brown 2001-03-14 17:22:27 EST
*** Bug 30553 has been marked as a duplicate of this bug. ***
Comment 13 Richard Hyde 2001-03-15 00:46:22 EST
[root@a-bomb /root]# cat /etc/redhat-release 
Red Hat Linux release 7.0.91 (Wolverine)

17. serverURL          https://www.rhns.redhat.com/XMLRPC      


What site does have knowledge of the betas?  Some versions of up2date do work,
so what is the correct server to point to?

Comment 14 Jay Turner 2001-03-15 08:45:19 EST
You should be able to run 'up2date --config --nox' and set serverURL to
'https://beta.rhns.redhat.com/XMLRPC' and you should be good.

Note You need to log in before you can comment on or make changes to this bug.