Bug 294871 - Surround sound stopped working on Intel 82801G when upgrading 2.6.20->22
Surround sound stopped working on Intel 82801G when upgrading 2.6.20->22
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 294851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 11:13 EDT by Carl-Johan Kjellander
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 17:18:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/asound.state (7.29 KB, text/plain)
2007-09-18 11:15 EDT, Carl-Johan Kjellander
no flags Details

  None (edit)
Description Carl-Johan Kjellander 2007-09-18 11:13:27 EDT
Description of problem:
We used to have 4 channel sound working on a Kontron 986LCD
m/ITX-board with onboard sound:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
 
But that was before the upgrade from 2.6.20 -> 2.6.22

Version-Release number of selected component (if applicable):
kernel-2.6.22.2-42.fc6

How reproducible:
100%

Steps to Reproduce:
1. speaker-test -Dplug:surround40 -c4
  
Actual results:
Sound in front L, R, silence in rear L, R.

Expected results:
Sound in all 4 speakers.

Additional info:
Booting back into 2.6.20, and everything works fine.
We have tried removing /etc/asound.state and letting
the system regenerate it. We have tried muting and unmuting
every single knob in alsamixer and volume-controls, with
no result.

Since the surrond used to work it shouldn't be impossible to
find the bug and fix it.

I can attach /etc/asound.state if you need it.
Comment 1 Carl-Johan Kjellander 2007-09-18 11:15:29 EDT
Created attachment 198461 [details]
/etc/asound.state
Comment 2 Carl-Johan Kjellander 2007-09-18 11:16:22 EDT
Example of a working kernel is:

kernel-2.6.20-1.2962.fc6
Comment 3 Chuck Ebbert 2007-09-18 12:53:58 EDT
There is probably a workaround, see

  http://alsa.opensrc.org/index.php/TroubleShooting

Also, can you try the Fedora 8 test2 live CD to see if the problem is fixed in
the latest development kernel?

Just as an example, HP Pavilion tx 1000 series needs this in /etc/modprobe.conf
to make it work, it was found by trial and error:

  options snd-hda-intel index=0 model=3stack position_fix=0 single_cmd=0
Comment 4 Carl-Johan Kjellander 2007-09-18 21:36:06 EDT
*** Bug 294851 has been marked as a duplicate of this bug. ***
Comment 5 Carl-Johan Kjellander 2007-09-19 09:09:38 EDT
Changing it to this in /etc/modprobe worked:

  options snd-hda-intel index=0 model=6stack-dig

How does the autodetection of these stacks work?
Comment 6 Chuck Ebbert 2007-09-19 11:19:12 EDT
(In reply to comment #5)
> Changing it to this in /etc/modprobe worked:
> 
>   options snd-hda-intel index=0 model=6stack-dig
> 
> How does the autodetection of these stacks work?
> 

There is a list of systems and the model they need in the kernel source. If the
Fedora 8 Test2 Live CD works, then your system is already in that list for the
next release. Otherwise the driver tries to guess what model to use.
Comment 7 Chuck Ebbert 2007-09-21 17:18:28 EDT
Will be fixed in kernel 2.6.23, in Fedora 8 on release and Fedora 7 soon afterwards.

Note You need to log in before you can comment on or make changes to this bug.